Problem with a new hdmi display on iMX6 [SOLVED]

I have changed my tft disaplay with a new one.
The new one is a Microtips 10.1" HA-101ZIEBCAH1-A (see attached datsheet) connected via HDMI (attached the EDID)
link text
I use a custom linux OS

The new display doesen’t disaplay any valid picture.
I’ve tested different solutions readed on the community without success.
I try to report the situation starting with a bios setup

vidargs = mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,1280x800M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M

(look at photo 1.jpg within uboot before booting)

…then booting I can see video parameters were not accepted

# fbset -s
mode "640x480-60"
        # D: 25.200 MHz, H: 31.500 kHz, V: 59.999 Hz
        geometry 640 480 640 480 16
        timings 39683 48 16 33 10 96 2
        accel false
        rgba 5/11,6/5,5/0,0/0

Then I’tried to set it manually

# fbset -g 1280 800 1280 800 16
[  776.408746] mxc_sdc_fb fb@0: 1280x800 h_sync,r,l: 96,16,48  v_sync,l,u: 2,10,33 pixclock=25199000 Hz

(look at photo 2.jpg after fbset -g 1280 800 1280 800 16)

…and again changing timings

# fbset -t 14084 48 80 3 14 32 6   (values readed in a vesa standard list)
[ 1012.844633] mxc_sdc_fb fb@0: 1280x800 h_sync,r,l: 32,80,48  v_sync,l,u: 6,14,3 pixclock=71002000 Hz

(look at photo 3.jpg after fbset -t 14084 48 80 3 14 32 6)

Then I’ve tried to clear vidargs (setenv vidargs ‘’)

# fbset
mode "1024x768-60"
        # D: 65.003 MHz, H: 48.365 kHz, V: 60.006 Hz
        geometry 1024 768 1024 768 16
        timings 15384 160 24 29 3 136 6
        accel false
        rgba 5/11,6/5,5/0,0/0

(photo 4.jpg deleting vidargs – black screen)

I don’t know where to point to now.
The display is given for 1280x800 but vidargs with 1280x800M@60 seems not recognized.
The default value seems to be 1024x768@65 but no images are displayed.

I have tried many different combination with fbset timings with any resoults (no images but just lines).

I look forward for a help.

Hi @Alessandro

Your problem is probably related with mine described in this topic.

I have successfully set up display with xrandr command as

# list available modes
cat /sys/class/graphics/fb0/modes

# set new mode
xrandr --output "DISP3 BG" --mode "<mode>"
# In my case
xrandr --output "DISP3 BG" --mode "D:480x1280p-60"    

Hi, thank you for the help.
I don’t have xrandr commans in my OS "-sh: xrandr: not found
" … is it possible to install?

For tests I have done that in toradex official lxde bsp3.0b4 image.

Which linux image do you have installed?

Hi @Alessandro ,

if it helps, I have used this workaround that benjamin.tx described until the issue is resolved. This workaround requires kernel modification and rebuilding of kernel image.

Regards, Mlinar

Hi @mlinar

Thanks for your Input.

Best regards,

Hi mlinar, thank you for the help, anyway I have solved the issue changing the mxc_hdmi.only_cea from 1 to 0.
I have noted that the u-boot setting of vidargs at 1280x800@60 was not conserved during the boot … after the boot squence the fbset result was a poor 640x480…

The problem seems to be that the 1280x800 was not recognized as a valid setting so it is deleted.
My final

vidargs=mxc_hdmi.only_cea=0 video=mxcfb0:dev=hdmi,1280x800M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M

useful link is link text

with info about the vidargs settings

Hi @Alessandro and @mlinar

Perfect that the issue is solved. Thanks for your feedback.

Best regards,