Problem while upgrading WinCE

I think I missed some section of the documentation and now I have a problem on my VF61 module.
In the past I upgraded WinCE 6 to version 1.3 using the bootloader and an SD card as described here.
I’ve just tried to upgrade to WinCE version 1.4Beta1 and, reading the disclaimer I thought I can use UpdateTool only.
I upgraded the OS image (nk6.bin) but now the module boots but it can’t see the hardware (USB, RSR232, SD card, …). Reading this thread I suspect I had to upgrade the bootloader before upgrading the OS image (unfortunately I didn’t find this info before).
When I launch UpdateTool, I see the error “Module HW version not supported”. Moreover, RS232 doesn’t work anymore so I can’t see any message during the boot phase.

How can I fix this issue and upgrade the bootloader? Or downgrade the OS image, maybe?

Put the bootloader on SD card and connect UART A to your PC. When its booting press space and enter the bootloader. This should allow you to flash new bootloader. Also remember to clear the registry before booting.

Unfortunately, in this situation RS232 (UART A) doesn’t work anymore so I can’t see any message during the boot phase.
It seems that only Active Sync connection over USB works

Try recovery mode http://developer.toradex.com/knowledge-base/colibri-vf50-vf61-wince-bring-up

Than only recovery mode can help. http://developer.toradex.com/knowledge-base/vfxx-recovery-mode

I follow the steps for recovery mode, but when I enter the boot console and I send flashloader I get the following error (see attached image)

Error initializing SDHC1

I use a 8GB Transcend SD card. Is there a problem with my SD card?
How can I proceed?253-error.png

I tried an old 64MB SD card from Digital Media but I see exactly the same error initializing SDHC1

Can you download this → https://share.toradex.com/r07ieh80qsub7pg
And put this image to SD card using Win32 disk imager. After that try the recovery mode again.

This image burns some files on the SD card, but while trying the recovery mode I get the same error initializing SDHC1

Can you try writing this command

eraseflash 0 512mb nocheck
restorefactoryinfo → with proper parameters
writebcb
flashloader

Do you mean writing exactly this command

eraseflash 0 512mb nocheck restorefactoryinfo -> with proper parameters writebcb flashloader

instead of flashloader command?

If this is the case, I get the message “Invalid Command”.
If this is not, please clarify what I should enter and where.

OH half of my post was deleted.
Enter this commands one per line

eraseflash 0 512MB nocheck
restorefactoryinfo
writebcb
flashloader

When enterning restorefactoryinfo you have to enter some information about the module. It will print out the correct form.

Unfortunately this doesn’t help

257-error.png

I see that this happened on a different module (imx6S), but could be my issue related to this one?

Good news!
I found the reason for “Error initializing SDHC1” and I want to share it (maybe it can help someone else).

  • Before trying to do an OS update, all the jumpers of connectors X8 and X11 on the Colibri Evaluation Board mus be reset to their factory position (i.e. plugged)
  • Moreover, disconnect everything (cables, devices, resistors, …) you could have connected to X7, X9, X10, X12 connectors of EVB

I had an external board connected to EVB using the above general purpose connectors and I think this produced some kind of conflict over the SD card bus.

After having disconnected everything, I was able to successfully reinstall bootloader and WinCE usign the standard documentation from Toradex.