Problem installing openjdk-8 (libc6 dependency)

After running opkg update I am trying to install openjdk-8. There are problems with the version of libc6 but I am unable to upgrade that package as well. There appears to be two versions of libc (2.22-r0.3 and 2.22-r0) available in the repo but I don’t know if that is related to the issues I am having.

[root@lx2000-05 ~]# cat /etc/angstrom-version
Angstrom v2015.12 (Core edition)
Built from branch: HEAD
Revision: 1f4bfa33073584c25396d74f3929f263f3df188b
Target system: arm-angstrom-linux-gnueabi
[root@lx2000-05 ~]# opkg install openjdk-8
Installing openjdk-8 (72b05-r0.0) on root.
Not selecting libc6 2.22 as installing it would break existing dependencies.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openjdk-8:
 * 	libc6 (>= 2.22) * 	libc6 (>= 2.22) *
 * opkg_install_cmd: Cannot install package openjdk-8.
[root@lx2000-05 ~]# opkg list | grep libc6
libc6 - 2.22-r0.3 - GLIBC (GNU C Library)  The GNU C Library is used as the system C library
libc6 - 2.22-r0
[root@lx2000-05 ~]# opkg list_installed | grep libc6
libc6 - 2.22-r0
libc6-thread-db - 2.22-r0
[root@lx2000-05 ~]# opkg upgrade libc6
Not selecting libc6 2.22 as installing it would break existing dependencies.
Not selecting libc6 2.22 as installing it would break existing dependencies.
Assuming locally installed package libc6 (2.22-r0) is up to date.

You may need to force downgrade and force dependencies due to faulty non-standard versioning used by the upstream Linaro packages:

opkg install --force-downgrade --force-depends openjdk-8

You may anyway find that openjdk-8 installs correctly despite complaints about not selecting packages that would break existing dependencies.

Thank you Brandon for the quick reply.

Unfortunately this did not work for me.

[root@lx2000-05 ~]# opkg install --force-downgrade libgcc1 libc6
Package libgcc1 (linaro-5.2-r2015.11-2) installed in root is up to date.
Not selecting libc6 2.22 as installing it would break existing dependencies.
Not selecting libc6 2.22 as installing it would break existing dependencies.
Unknown package 'libc6'.
Collected errors:
 * opkg_install_cmd: Cannot install package libc6.

adding “–force-depends” will likely resolve this issue, let me know if that works

adding “–force-depends” worked to upgrade libc6 but installing opendjk-8 still failed unless I added “–force-depends” to that install as well.

I now have libc6 - 2.22-r0.3 and opendjk-8 installed.

Right now it seems I am able install packages but only if I add “–force-depends” for all the opkg installs or upgrades.

@dhammer Thanks for the feedback, I will update the answer accordingly. I apologize for the issue here. Unfortunately, the upstream Angstrom repositories have built packages with different builds of the same c/gcc versions as our image. This should hopefully be cleared up by the next Angstrom release that we build on.