Problem installing android in my toradex apalis imx6

i am trying to install android in my apalis imx6 module i have downloaded the respective os for it from toradex official website
on successfully downloaded it i installed it on my toradex board…it is installed perfectly but on completion when it reboots then it doesnt show anything…what can be the problem…is it not supported on apalis imx6?
in the website its is mentioned for apalis imx6 but it didnt work for me…

Hope for an early reply from your end…
Thanks…

I’ve tested latest android image for Apalis iMX6Q and it works OK. Could you provide more details about your case?

  • How exactly did you flash it?

  • Do you have any output on debug serial console?

  • Any other details?

i have downloaded the android version from toradex official site. it was a zip file which i unziped and copied i to my pen drive…and I follow the same procedure for installation like that for all the previous which i have installed…i.e i kept my development board in recovery mode…and then run tezi from recovery-windows.bat and after that the displays come and from feeds section i install the Android for my apalis imx6…
It installed successfully but at the time of reboot nothing is shown…

Hi @akshat

As @alex.tx said could you provide the console output in text format?

It installed successfully but at the time of reboot nothing is shown…

You need to do manually power on/off or push the reset button on the Ixora Carrier Board.

Thanks and best regards,
Jaski

Hi Guys,
Facing the same issue, Can anyone tell me, why I am facing below error while flashing android9.0 images to toradex imx6q SOM.

Device-Info:-
Device: FSL_SDHC Manufacturer ID: 13
OEM: 14e Name: Q2J54 Tran Speed: 52000000 Rd Block Len: 512 MMC version 5.0 High
Capacity: Yes Capacity: 3.6 GiB Bus Width: 8-bit Erase Group Size: 512 KiB HC WP Group Size: 8 MiB User Capacity: 3.6 GiB WRREL Boot Capacity: 2 MiB ENH RPMB Capacity: 512 KiB ENH

Flashing-Steps:-
.\uuu_imx_android_flash.bat -f imx6q -p sabrsd -e error:

1:2 1/22 [ ] FB: ucmd setenv fastboot_dev mmc
Success 0 Failure 1

Thank you , quick help will be appreciated.

Hi @shilesh

Could you provide the version of the hardware and software of your module?
How did you flash the android image? Where did you got flash tool?

Best regards,
Jaski

How to restore the SOM?

I’m faceing the same issue on Apalis imx6Q 2GB on Ixora carrier board.
No output to the console after reboot, nothing on the screen.

I’ve installed official Kinectics Android from Toradex Easy Installer after download it from the website.

What I have to do?

Kind regards,

Matteo

You can restore SOM by loading Toradex Easy Installer over USB and flashing new image using it.