Pppd connection with the static IP for the eth0


There is a issue with the connectivity of pppd with the static IP on boot,

The ppp is using the default route to transfer the packets which I am able to communicate the packets to the desired server when no connection is present on the ethernet port (no ethernet connection on eth0)

Once you connect an ethernet port the default ip is replaced with the which stops the packet transfer and unable to send the packets.

Currently my IP to the eth0 is set to static.
I am trying to set the default gateways on boot so that the pppd connection takes the desired default route.
Can you please suggest on the same.

Thanks in advance


It seems like the system is replacing the default route to whenever the Ethernet connection is active. One way to solve this issue is by adjusting the routing table to use different gateways for different connections. In your case, you’d want to ensure that the PPPD connection uses its own specific gateway even when the Ethernet connection is active.

This link may be useful

Hi @Basava.lg

Kindly let us know if you are still facing the issue.
Also please attach some debug logs and setup you already tried to further look into the matter.

Best Regards
Ritesh Kunar

Dear Ritesh, Alex

Thanks for your inputs,
I tried doing the suggested settings and i am unable to set up the different route table on boot.

What I am trying to do is setting up the route table for transferring the data packets through the GSM network using pppd, where I need to set up the default route for the ppp0 interface, which I am trying to after the network is up.

These are the exercise which I have done

executing command
#route add default route ppp0
This command is executed from the bash script which is placed inside the

Please find the snaps for the log information:
The ppp0 network availibility

This is the pppd logs after the connection is established when no ethernet is connected.

If an ethernet connection is made than the default route is replaced with for the eth0

Kindly please help me in this.

Thanks and Regards,
Basavanagouda G


I am able to resolve the replacing the default route of the pppd connection and setting up the default route in ppp configuration file.
1. Add the defaultroute-metric to /etc/ppp/peers/provider (Which is the pppd configuration)
2. Remove replacing the replacedefaultroute in the /etc/ppp/peers/vivo-3g.provider

Thanks for your support

Basavanagouda Ganganagoudar