Polish Language

Hello, curently i am working on application for Colibti t20 with wince 7. I made wince image with only Polish and English locale. Aplication should work in English and Polish language but after change locale setting for Polish, i recive “PlatformNotSupportedException”. Reason for this is probably lack of Polish characters. I tried to look for Polish Language pack but i couldnt find it. Is there a way to get Polish characters in to my wince 7?

Can you check if what is suggested in this article:


fixes your issue?

P.S. the article was in our knowledge base but did not appear in searches, I hope I fixed the issue now.

Solution presented in this article adds locale but i cant check if codepage 1250 (ANSI-Central Europe) is added with it. If it adds then is there any other possible reason why my aplication works on English locale but isnt on Polish? I checked it on other mobile device i have which i am sure that have codepage 1250 and aplication works perfectly.

Dear @awoj

Can you send us some more information please:

  • How do you switch the locale?
  • Can you send us a code snipped to reproduce the problem, or at least tell us which function fails with what kind of error, so we have a way to reproduce the problem.

I installed the additional locales from the page that Valter linked in his answer, and switched the locale to Polish using the Control Panel → Regional Settings → Regional Settings, and opened the clock from the system tray. At least the month names in the calendar look Polish, with some special characters. Therefore I think the basic functionality should work.
Are you possibly using a font which does not contain all local characters?

Regards, Andy

I downloaded OSDesign for WinCe 7.0 from Toradex site and i have SDK BSP also from Toradex. In the OSDesign only thing i done was in Catalog Item View at “Core OS\ Windows Embedded Compact\ International\Language\Polish\Locale” check Polish and Polish(Poland) boxes. Then in configuration manager i switched “Active Solution Configuration” from Debug to Release. Made clean sysgen and instaled on Colibri T20. Then I made for test C# smart device application with one form with just one label. Label shows different text for default language and different for polish. Basicaly i just added label to form without writing even line of code. After changing build options to release i builded it. When i have English(United States) regionals i see default label, but when i have Polish regionals i get error “PlatformNotSupportedException at System.Globalization.CompareInfo.ctor(Int32 culture) at…”. Application was tested on different smart device with WinCe 6.0 and it works as intended (shows different label on English and Polish regionals). I hope you can find out why it works like that.

Dear @awoj,

Could you please share the sample DotNet project with us. Please upload it in https://share.toradex.com/ and post the link here.

Here is link to all files of my test project:TestProj

As i experimented with your project i found out it is problem with localization. When you click on form in propertiesyou have option “Localizable” and “Language”. It allows to see different things depending on wchih locale is set. It is important feature in our aplication so it have to work. And in your test project orginaly there was no localizable resources. When i added localization for German, French and Polish language(changed “text” property of Form1 depending on language) i observed strange reaction. In German and French language application works but instead of dedicated text i see default one while in Polish i get error.

Dear @awoj,

Thank you for your feedback. We are not an expert dot net compact framework. Also, it seems to be .NET Compact framework would need additional effort to make it work with language localization. So, could you please help yourself to look into the issue.

You would get some references from the links below



In case, if you need to build custom image then please use our binary BSP and workspace to do that.

Let us know if you face any issue on that.