Pinmuxed specific pins to SPI, kernel is trying to use pins not specified and returning error that pins are already used

I mofied SPI1 in the device tree to use specific pins:
0x0ec 0x400 0x7dc 0x2 0x1 0x100b1
0x0e8 0x3fc 0x7e0 0x2 0x1 0x100b1
0x0e4 0x3f8 0x7d8 0x2 0x1 0x100b1
0x0f0 0x404 0x7e4 0x2 0x1 0xb1

In the kmsg I get this error:

3,140,1300801,-;imx6dl-pinctrl 20e0000.iomuxc: pin MX6DL_PAD_EIM_EB1 already requested by 20e0000.iomuxc; cannot claim for 2008000.spi
3,141,1316450,-;imx6dl-pinctrl 20e0000.iomuxc: pin-114 (2008000.spi) status -22
3,142,1325401,-;imx6dl-pinctrl 20e0000.iomuxc: could not request pin 114 (MX6DL_PAD_EIM_EB1) from group ecspi1grp  on device 20e0000.iomuxc
3,143,1341406,-;spi_imx 2008000.spi: Error applying setting, reverse things back
4,144,1350529,-;spi_imx: probe of 2008000.spi failed with error -22

 I double checked that I assigned the correct values in iomuxc but for some reason the log says that the kernel was trying to assign "MX6DL_PAD_EIM_EB1" to spi@2008000, which has already been requested by 20e0000.iomuxc. I tried to find out where this pin leads too in the imx6dl-pinfunc.h and imx6q-pinfunc.h files but it doesn't point to a specific ball name, just the general group of options for _EIM_EB1.  I'm not sure why it's attempting to use pads I didn't request. 

I’ve attached a copy of my device tree .dts file and the full kmsg log from my last run.

Thank you.

link text

link text

Sorry for the confusing post, I’m trying to get used to posting code block and etc.

What exact hardware (module and carrier board) and software (also downstream vs. mainline/upstream) versions of things are you talking about?

Colibri iMX6 256 MB IT version. Custom carrier board I designed myself. I’m using the Embedded Linux Minimal Image as a starting point. We are connecting an ArduCAM OV5642 to SPI and I2C. A the moment we’re focusing on pinmux for SPI and we’re getting the error above.

ECSPI1 seems to be trying to use pin 114 MX6DL_PAD_EIM_EB1 which is already taken up by another node, even though I didn’t request it to use that pin.

Our software is custom software we’re making to use the cameras, but it’s high level compared to the device tree we’re trying to figure out now.

I don’t suppose anyone has any idea what’s wrong?

I tried to find out where this pin leads too in the imx6dl-pinfunc.h and imx6q-pinfunc.h files but it doesn’t point to a specific ball name,

You should look not in *.h files but in related *.dts and *.dtsi files in arch/arm/boot/dts, file pattern perhaps imx6*. There are some matches in imx6qdl-colibri.dtsi and others. pinctrl_wem_gpio_4 group includes your pad, and group is included in imx6dl-colibri-eval-v3.dts.

Please read this.