Opkg: Couldn't find anything to satisfy 'libxss1'

Trying to test Electron as per this Blog entry: Erstellen von graphischen Interfaces für Embedded LInux mit Electron

But installing libxss1 via opkg failes:

root@apalis-imx6:~# opkg update
root@apalis-imx6:~# opkg install libxss1
Collected errors:
  * opkg_prepare_url_for_install: Couldn't find anything to satisfy 'libxss1'.

I can remember installing Electron on a Linux Image Version 2.7 a couple of months back and it worked. Can you suggest a solution for Linux Image 2.8?


libxss1 is not necessary on 2.8 images

When starting electron I get this error:

root@apalis-imx6:~/electron-samples/electron-sample-apps# cd frameless-window
root@apalis-imx6:~/electron-samples/electron-sample-apps/frameless-window# ~/electron-latest/node_modules/.bin/electron .
/home/root/electron-latest/node_modules/electron/dist/electron: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

I tried installing libXss1 from the v2016.12 feed manually. After that electron will start without that specific error but the application will not load correctly - nothing in the electron browser window is displayed (empty frame) and I get a bunch of errors in the console specific to the application. Tried it with electron 1.8.4 and beta release. Same result.
So I guess this is not the way to go. :slight_smile: Will switch back to image 2.7 for now.


I made some tests with Embedded Linux BSP 2.8b2 here, follow below steps how to install electron:

opkg update
opkg install nodejs nodejs-npm libxcb-screensaver0 cups libxcomposite nss libxi freetype libxtst gconf libxrandr atk cairo gtk+ fontconfig libasound nspr pango gdk-pixbuf libxcursor libxdamage libxfixes libxrender 

npm init
npm install electron
ln -s /usr/lib/libxcb-screensaver.so /usr/lib/libXss.so.1

root@colibri-imx6:~/electron-sample-apps/frameless-window# /home/root/electron-framework/node_modules/electron/dist/electron -disable-gpu .

Apparently libxscrnsaver should provide libXss file, since when image is built with OpenEmbedded it does not get errors.

I’m going to update blog post accordingly.

Thanks a lot, that works! (Sorry, downvoted by accident)

hi…, i am new to js node.,

i tried in imx7 1gb with latest beta version…, but i finding following error… kindly guide me

root@colibri-imx7-emmc:~/electron/samples/electron-sample-apps/frameless-window# home/root/electron-framework/node_modules/electron/dist/electron -disable-gpu
-sh: home/root/electron-framework/node_modules/electron/dist/electron: No such file or directory

Could you ask a new Question with proper issue description, please? Thanks.

Hi there I am getting the same issue for iMX7d, bsp2.7


BSP 2.7 is not supported anymore. Please upgrade to BSP 2.8.7 and follow these instructions to deal with the dependencies.