Old Colibri iMX8DX 1GB version 1.0B Loading Toradex Easy Installer

I found at the bottom of a drawer old version of " Colibri iMX8DX 1GB version 1.0B"
Is possible Loading Toradex Easy Installer from USB OTG ?

On “linux-software-downloads” I see special version for Colibri iMX8X V1.0B
But on Toradex Easy Installer no special versions for imx8x V1.0B

Colibri-iMX8X_ToradexEasyInstaller_5.4.0+build.4 → recovery-windows.bat
error message :frowning:

Downloading Toradex Easy Installer...
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.127-0-g08c58c9

Success 0    Failure 0    Wait for Known USB Device Appear...
Error: Timeout: Wait for Known USB Device

uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.127-0-g08c58c9

Success 0    Failure 1

1:2      1/ 1 [HID(W):LIBUSB_ERROR_IO                ] SDPS: boot -f ../imx-boot

ECHO is off.
Downloading Toradex Easy Installer failed...

Can I use old “iMX8DX 1GB version 1.0B” or is it better to scrap it ?

Hi @MariusM

Toradex Easy Installer 5.4.0 is the last version that supports the V1.0B early access module. It should work to still use it, however we implemented a compatibility mode in the Easy Installer which will only try for 1s to download the Easy Installer to V1.0B module after calling recovery-windows.bat. Make sure to follow this guide to make it work:

  1. Put your module into recovery mode (keep recovery pressed for >10s until it shows up in device-manager as NXP recovery device)
  2. After you see it being in recovery-mode in device-manager you can call the recovery-windows.bat

You can still use your module with BSP version up to 5.4.0, however we do no longer release software for it going forward.

Best Regards,

I confirm the problem is solved !
The order matters for version V1.0B , first recovery mode then recovery script :wink:
My bad habits: on iMX8QXP always start first recovery script then turn on device in recovery mode
Everything is clear

Hi @MariusM ,

thanks for letting us know that it worked.

Best Regards