Nothing RPROVIDES 'gstreamer1.0-plugins-imx'

Hi, Im trying to build for colibri-imx6 (dl)

ERROR: Nothing RPROVIDES 'gstreamer1.0-plugins-imx' (but /home/ubuntu/roby/imx6/build/../layers/meta-myos/recipes-core/images/ RDEPENDS on or otherwise requires it)
gstreamer1.0-plugins-imx was skipped: incompatible with machine colibri-imx6 (not in COMPATIBLE_MACHINE)


# video
MACHINE_HWCODECS ?= "gstreamer1.0-plugins-imx"

MACHINE ??= "colibri-imx6"
DISTRO ??= "poky-os"

What Ive tried:

PREFERRED_VERSION_gstreamer1.0              = "1.20.3.imx"
PREFERRED_VERSION_gstreamer1.0-plugins-base = "1.20.3.imx"
PREFERRED_VERSION_gstreamer1.0-plugins-good = "1.20.3.imx"
PREFERRED_VERSION_gstreamer1.0-plugins-bad  = "1.20.3.imx"

Series im using:

    url: ""
    branch: kirkstone
    path: layers/meta-freescale

    url: ""
    branch: kirkstone
    path: layers/meta-freescale-3rdparty

    url: ""
    branch: kirkstone-6.x.y
    path: layers/meta-toradex-bsp-common

    url: ""
    branch: kirkstone-6.x.y
    path: layers/meta-toradex-nxp

Any idea?

Looks like setting IMX_DEFAULT_BSP = "nxp" did the trick and its compiling fine now. However I’m stlil curious what was causing the issue

Hi @robs !

Thanks for sharing what solved your issue!

From the information you shared in your initial question, seems like you are creating your own distro.

You might want to check how such configuration is done on the reference distros contained in Toradex’s layers to understand how we do it.

Here is how you can get all of them:

I marked your message as the solution.

Have a nice day!

Best regards,