Not able to recover VF61 using UART A and

I could use help with this problem. To simulate our custom board, I’m using Toradex Col Eval 3.2 with Col VF61 v1.2A processor. I erased NAND Flash to remove Windows eboot expecting that I could put it back by using UART A interface. However, I see nothing on the minicom terminal when I power the eval board. I tried pressing the recovery mode switch prior to power to place the processor in recovery mode. I’ve tried shorting the recovery pads together on the SOM. If I execute “ -d /dev/ttyUSB0”, it fails with the error response “sudo: unable to execute vf_flash/imx_uart: No such file or directory” which I believe is caused by the VF61 processor not in recovery mode and not listening to UART A. I have followed the procedures in “VFxx Recovery Mode” repeatedly with no results. I’m using Ubuntu 14.04 Linux.

Background: We’re building custom board that will include the Toradex VF61 SOM. The board will not have SD card or USB port. It will have UART A interface and Ethernet . Our goal is to be able to remove Windows Eboot, somehow flash u-boot using UART A then have u-boot TFTP Linux over Ethernet.


Likely you are on a 64 bit machine and the 32-bit libraries are not installed.

e.g. try to execute the download utility directly and I expect you will see the same error instead of the utilities help text:

vf_flash/imx_uart -h



Thank you. This was exactly the problem. Imx_uart is working now and it appears to flash u-boot. However, I see no signs of life from the VF61. Any ideas? My output is below.


Don -d /dev/ttyUSB0
Colibri VF rootfs detected
Put the module in recovery mode and press [ENTER]...

config file 
parse vf_flash/vybrid_usb_work.conf
starting associating phase
association phase succeeded, response was 0x23454523
HAB security state: development mode (0x56787856)
== work item
filename colibri-vf_bin/u-boot.imx
load_size 0 bytes
load_addr 0x00000000
dcd 1
clear_dcd 0
plug 1
jump_mode 2
jump_addr 0x00000000
== end work item
No dcd table, barker=402000d1

loading binary file(colibri-vf_bin/u-boot.imx) to 3f4073d0, skip=0, fsize=6fc30 type=aa

<<<457776, 457776 bytes>>>
succeeded (status 0x88888888)
jumping to 0x3f4077d0

Hi Don,

Hm, the output looks good. Make sure to disconnect the serial terminal during -d .... Once the command succeeded, you should get a Toradex Logo on parallel RGB (e.g. VGA on Eval board). When reconnecting to the serial terminal on UART_A and press enter, you should see a U-Boot prompt.

Please proceed according to the flashing from scratch procedure as indicated in the following article on our developer website.

Hi max,
Thank you so much! This was the last clue I needed. Not sure what article I read on the developer site that sent me down the power cycle path. The good news is I’ve recovered the VF61 processor and now understand the process. Again thank you

Hi Don -d ... loads the U-Boot binary into RAM and executes it there.
Power cycling after -d ... isn’t a good idea.

So after -d ... you would launch a terminal program to continue flashing the full image (which includes U-Boot) into NAND.


Thanks everyone. The above steps have resolved my recovery issue.

Thanks for the suggestion. I tried loading running update from Colibri_VF_LinuxConsoleImageV2.6 and from Colibri_VF_LinuxImageV2.5. Both succeed but I never see the u-boot prompt on the serial interface when I power off and on. It appears the processor is stuck in recovery mode. Any ideas or suggestions are appreciated. Thanks!


How much time it will take to recover the module? Mine is waiting at “loading binary file(colibri-vf_bin/u-boot.imx) to 3f4073d0, skip=0, fsize=6fc30 type=aa” since 20 minutes.

There is no prints after that. Any idea?