No screen Quickstart Guide w/ Apalis iMX8QP 2GB V1.1C on Ixora V1.2A

as I saw this issue seams to be quite common or at least I am not the first one w/ this problem. I started with the Quickstart Guide and i stuck since days that I did not get any HDMI signal or at least no image on the monitor.

Apalis iMX8QP 2GB V1.1C w/ Ixora V1.2A carrier board

Installed Operating system
TorizonCore with evaluation containers

The Toradex Easy Installer was displayed on my screen but after the installation of the operating system I am unable to get anything on my monitor.

I tried two different monitors

  1. BA92
  2. Acer BA247Y

For the Acer I tried different HDMI cables and several different resolution settings by the command “setenv tdxargs video=HDMI-A-1:…x…” and saveenv

For the other screen (BA92) I tried also everything I could find in this community but no success. Boot log and fbset attached
800x600.txt (2.6 KB)

Who can help?

Best regards

Greetings @Abfuellwelt001,

There is currently an issue on our 5.7.2 image where the default graphical UI is bugged and doesn’t show up. However, this is just an issue with the UI and not the actual HDMI interface itself. Can you try running something graphical on the command line like a Weston container for example:

docker run -e ACCEPT_FSL_EULA=1 -d --rm --name=weston --net=host --cap-add CAP_SYS_TTY_CONFIG \
             -v /dev:/dev -v /tmp:/tmp -v /run/udev/:/run/udev/ \
             --device-cgroup-rule='c 4:* rmw' --device-cgroup-rule='c 13:* rmw' \
             --device-cgroup-rule='c 199:* rmw' --device-cgroup-rule='c 226:* rmw' \
             torizon/weston-vivante:$CT_TAG_WESTON_VIVANTE --developer weston-launch \
             --tty=/dev/tty7 --user=torizon

Make sure no other containers are running when you execute this.

Best Regards,


thanks a lot for this quick feedback. As I am quite new to those kind of soft- and hardware I need some more support.

  1.  How can I check that no other containers are running?
  2.  How can I run your example?

In generall I assume that this is just a quick check wheather my problem is related to the known issue of image 5.7.2. But how can I fix it?

Kind regards

Hello @Abfuellwelt001

Run docker container ls

Just run the command that @jeremias.tx wrote. It should work.

Can you also send us the output of dmesg when you connect and disconnect the HDMI monitor?

Best regards,

thanks a lot. After I run the command that @jeremias.tx wrote the screen showed up a window (Wayland Terminal)

Afterwards I run the dmesg command:

  1. output of dmesg when HDMI monitor connected
    dmesg w HDMI.txt (41.4 KB)
  2. output of dmesg when HDMI monitor disconnected
    dmesg wo HDMI.txt (41.6 KB)
    I could not detect any differences.

But after a reboot the screen is gone and I am unable to see the “normal” Portainer login window. So I cannot proceed w/ the Quickstart Guide as I am not getting to the Portainer view.
Is there any permanent fix for this issue?

But after a reboot the screen is gone and I am unable to see the “normal” Portainer login window.

Well as I said the current Portainer UI is bugged so it’s not showing up. Our team is currently working on releasing a fixed version soon. You can still proceed with using TorizonCore, portainer is just a UI and not required or vital for use on TorizonCore.

Best Regards,

Hello @Abfuellwelt001 ,
Were you able to progress with the quickstart? Do you need any further assistance on our side?

Best regards,