No other interrupt is working when Rpmsg is running

Hi,
I am working on M4 core in colibri imx8x. the issue which i am facing is external interrupt is not working when Rpmsg is running. I have tried these two peripherals seperate and it was working.
Any interrups are used for Rpmsg.?
If used is that is making clash with externel interrupt.?

Regards,
Ouseppachan CR

1 Like

Hi @Ouseppachan,

What two peripherals are you refering to?

Please note that the demos/SDK are provided by NXP

Hi @sahil.tx ,
I am using Lpspi and external interupt and Rpmsg. for both external interupt and Lpspi i have enabled IRQSTEER.
Pins am using are,
externel interupt - LSIO_GPIO0_PIN_30
SPI pins - SC_P_SPI2_SCK, SC_P_SPI2_SDI , SC_P_SPI2_SDO.

In case of Rpmsg from SDK example only i took code.

Hi,
Can is access shared memory in colibri imx8x board for communicating with linux and M4 core. If yes from what addres i need to use.

Hi @Ouseppachan ,
You can use RpMsg for communication between M4 and linux.
The demos are already provided by NXP inside the SDK.

Hy,
Solved this issue a decade before. thanks for the reply…

Thanks for updating and sorry for the delay as we are not actively providing support for MCU.