No hdmi console output Ixora/Apalis iMX8

I have an Apalis iMX8 on an Ixora Board with my own bitbaked image based on TorizonCore 5.7.0. I was expecting to get the console output on the HDMI.

I have tried to enable CONFIG_FRAMEBUFFER_CONSOLE as explained in No hdmi console output iMX8.

I have checked that /boot/ostree/torizon-2bea507b908d4cda199440967c4bc8c648c3a1a60bed4fc741b6ad9f9d8c739a/dtb/overlays.txt contains the line fdt_overlays=apalis-imx8_hdmi_overlay.dtbo.

Am I wrong in expecting to get the console output on HDMI?

Hi @jugge ,

Thanks for reaching out.

Do you see any output on the HDMI screen? After the module successfully booted for example?

Additionally, would you be able to send us a dmesg log?

Best Regards

Hi @kevin.tx,

I think I get connected to the HDMI screen, but that it is blank. This changes from disconnected to connected when I connect the HDMI cable and the display does not complain that no HDMI signal is present, as it does when no cable is attached.
$cat /sys/class/drm/card1-HDMI-A-1/status

This is the output of dmesg:
dmesg.txt (38.5 KB)

I plugged in and out the hdmi cable a few times, so here is dmesg output after that as well.
dmesg2.txt (40.8 KB)

Hello @jugge ,

The repository above holds the kernel configuration for TorizonCore and as you can see, CONFIG_FRAMEBUFFER_CONSOLE is enabled by default .

By default TorizonCore has the “quiet” property in the command line enabled.

Can you run the tdx-info tool and share its output?

And could you also share your use case? Why do you need to build TorizonCore?
TorizonCore Builder helps you to customize your image for several use cases.
Do you find any limitation in TorizonCore Builder for your specific use case?

Best regards,

Output from tdx-info

Software summary
Bootloader:               U-Boot
Kernel version:           5.4.193-5.7.0-devel+git.f78299297185 #1-TorizonCore SMP PREEMPT Mon Jul 11 14:42:03 UTC 2022
Kernel command line:      pci=nomsi root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.1/torizon/2bea507b908d4cda199440967c4bc8c648c3a1a60bed4fc741b6ad9f9d8c739a/0
Distro name:              NAME="****** TorizonCore Variant"
Distro version:           VERSION_ID=5.7.0-devel-20230131071611-build.0
Hostname:                 apalis-imx8-06804620

Hardware info
HW model:                 Toradex Apalis iMX8QM V1.1 on Apalis Evaluation Board
Toradex version:          0037 V1.1B
Serial number:            06804620
Processor arch:           aarch64

We are building TorizonCore since we need to use updated versions of docker and docker-compose, primarily to make use of real-time capabilities in later versions.

I removed quiet and plymouth.ignore-serial-consoles in /sysroot/boot/loader/uEnv.txt, and tdx-info confirms it is not there after reboot, but that does not have any effect on my HDMI behavior.

Hello @jugge
Can you try removing the kernel command-line parameter fbcon=map:3 ? Doing that you should get console output on the attached display.

Best regards,

Thanks @josep.tx,
That worked.
What functionality am I breaking by removing the framebuffer mapping?

Hello @jugge

No functionality is expected to be broken, you are only assigning a non-existing framebuffer to the console.
Here you can learn more about how the framebuffer console works. The point number 3 might be the most interesting for you .

Best regards,