No display on Apalis after flashing WEC 2013

I am trying to figure out why I can’ t get anything to show on the screen when WEC 2013 boots on my Ixora board with Apalis iMX6.

Here is what I did to flash WEC 2013:

  • Entered recovery mode and flashed Easy Installer.
  • Flashed WEC 2013 1.6-20191223.

Here is what I get on serial output:

Toradex Bootloader 1.6 for iMX6 Built Dec 23 2019
Splash screen is enabled.
Apalis iMX6D 512MB 1.1B Serial: 10741846
SPL enabled version.
Using 16MB of IPU memory and 80MB of GPU memory.
CPU is running at 792MHz.
Using eMMC boot partition (size: 32768 sectors).
Initializing L2 Cache.

Press [SPACE] to enter Bootloader Menu

System ready!
Preparing for download...
Loading compressed image...
Reading image from sector 40962.
Extracting 39965648 bytes from compressed image of 25291856 bytes

Launching image at 10200000.

Toradex Windows CE 8.0 1.6
 for iMX6 Built on Dec 23 2019
Apalis iMX6 Dual 1GB IT
Wait mode Disabled
SMP support enabled
CPU0 started
CPU1 started
RTC origin set to: 2006/01/01.
Registry is empty or invalid. Loading default values.
Registry loaded.
Loading GPIO Multiplexer...
Failed(0) Loading GPIO Multiplexer (0 ms)
Loading Clock...
GPU enabled.
DVFS not enabled.
Done Loading Clock (14 ms)
Loading SD Bus...
Done Loading SD Bus (1 ms)
Loading I2C1...
Loading I2C2...
Done Loading I2C1 (8 ms)
Done Loading I2C2 (14 ms)
Loading eMMC...
Loading UARTB...
Loading UARTC...
Loading SPI1...
Loading SPI2...
Loading Image Processing Unit...
Done Loading eMMC (48 ms)
Done Loading UARTB (26 ms)
Loading 2D/3D Graphic Accelerator...
Done Loading UARTC (26 ms)
Loading SD card...
Loading UARTA...
Done Loading SPI1 (26 ms)
Done Loading SPI2 (26 ms)
Loading external SD interface...
Port is used for OS debug!
Done Loading Image Processing Unit (23 ms)
Failed(0) Loading UARTA (14 ms)
Loading USB OTG...
Loading USB Host Controller...
Loading PMIC...
Loading Audio...
Done Loading USB OTG (77 ms)
Done Loading 2D/3D Graphic Accelerator (115 ms)
Done Loading PMIC (42 ms)
Loading Ethernet...
Loading Display...
Waiting for flash disk \Flashdisk for 30 seconds
Loading iMX6 PCIE driver...
Splash screen is not configured in config block, using setting from registry.
Done Loading iMX6 PCIE driver (16 ms)
Done Loading USB Host Controller (154 ms)
GPU2D enabled.
Done Loading Display.
Turning display ON.
Done Loading SD card (340 ms)
Loading Touch...
Maximum Allowed Error 5:
Done Loading external SD interface (334 ms)
Done Loading Touch.
SoftRTC disabled
RTC Time restored (12.10.2021 08:25:59)
RTCSync: Completed.
*** EMMC supports TRIM operation*** 85
bEnableTrim = 1
FATFS!FormatVolume: Formatting volume. Flags = 0x16.
Done Loading Ethernet (706 ms)
Ethernet: Disconnected
Done Loading Audio (775 ms)
Loading DHCP v4...
Done Loading DHCP v4 (0 ms)
Loading HDCP v6...
Done Loading HDCP v6 (0 ms)
Loading USB OTG Host...
Done Loading USB OTG Host (391 ms)
Unloading USB OTG Host...
Display: 640x480@60Hz PCLK: 25175000
Loading PP...
Loading NETUI...
Done Loading PP (19 ms)
Done Unloading USB OTG Host (133 ms)
No PCI link has been detected.
Ethernet: Connected at:  1000Mbps full duplex
Folder mounted
RTC Time set (12.10.2021 08:26:10)
RTCSync: Completed.

My monitor is connected to HDMI. I also tried VGA with an adapter. I also tried with two other monitors much older than the one I’m currently using. In all cases, I get no signal at all.

I tried with the previous version of WEC and I get the same result. Does anyone have any suggestions on where to go from here?

You need to set [HKLM\Drivers\Display\Apalis] Out parameter to 5.

Also you can set UseSplashSettings to 1 and configure display output and other parameters via eBoot SS settings.

Sorry, I’m still new to this. How can I apply the settings you suggest if I can’t get anything to show on the screen?

Changes to registry can be done using “Registry editor” included in WinCE image.
Changes to config block can be done by using Bootloader menu through debug UART.

Thank you, @alex.tx. I have applied these settings and the display works fine.

Thank you for the update. Glad your problem solved.