.Net CORE for ARM (T20)

I try to install the new version of .Net Core on Linux and I have problem to run the applications.
It’s showing Illegal instruction all the time

I found this link and didn’t helped

In the thread you’ve linked, there is an answer. It’s not supported on SoC without NEON. Unfortunately Nvidia T20 does not support NEON.

@dominik.tx thank you so much.
Do you think it’s working with t30?

Neon is supported in T30, check this out.

I’ll try t30 too
Thanks

You are welcome. Let us know if your application works with T30. Thanks.

@jaski.tx Next week I’ll receive T30 and let you know about it :wink:

ok, thanks.

T30 is compatible with .Net Core
It’s worked without any problem and i run AvaloniaUI on it.
to run Avalonia you should select one of the font you have installed and also use libSkiaSharp.so from RPi
https://github.com/toburger/skiasharp-raspberry/releases/tag/arm

Thanks @dominik.tx and @jaski.tx

Perfect that it works. Thanks very much for the feedback.

@jaski.tx your welcome. We will try i.MX 6 and 7 soon. and i’ll let you know again if they can run .Net Core or not. :wink:

Thanks. We will be glad to hear from you.

.Net Core and Avalonia working well on iMX6 and 7… Also We test Android + Xamarin and it’s working well on all CPU(s) (T20,T30, iMX6, iMX7)

Perfect. Thanks very much for this imporant Information.

Hi,
any Chance to run .net Core on i.MX7 & WEC2013?

Thanks for any Information.

With best regards

Gerhard

Please do not hijack any threads but ask a new question precisely stating what exact hardware and software versions of things you are talking about. Thanks!

See

https://github.com/dotnet/runtime/issues/32029

HI @Sinankaya and Welcome to the Toradex Community!

Do you have a question? If so, please ask a new one with proper description of your issue?

Thanks and best regards,
Jaski