MSMQ Service in Colibri vf61 Iris Win ce8


I want to run MSMQ Service in a Clolibri vf61 board (carrier board is iris). I build the OS including the MSMQ in the OS design in VS 2015. Port the nk.bin to the board using the “update tool” 5.7.1. Reboot.

Opening the registry editor, i see an entry “MSMQD” in HKEY_LOCAL_MACHINE\Services. Then in the command window when i run the comand “services.exe list” it shows an entry “MMQ1: 0x00841d03 MSMQD.DLL Off”. Then i run the command “services.exe start MMQ1:” it shows an error “Operation failed. Error code 0xc00e0001”. But I can easily start/ stop the FTPD and other services in the list.

Note: I did not face such problem with the Apalis iMX 6 in an evaluation board.

Again, i cannot delete the MSMQD entry from the registry. But i can rename it. When i rename it, then it can deleted. Then i save the registry (SaveReg option available in Colibri tools in the start menu). Then i refresh the registry. The MSMQD entry displayed again.

Any clue?

With regards,
Mridul Buragohain

These are the snapshots…link text

Latest Progress:

If I register the service using the command “msmqadm register” it successfully register the service returning a GUID. The next command “msmqadm start” fails. But now “services start mmq1:” successfully starts the service.

Next hurdle:
The MSMQ service does not start on next reboot. When i check it using “services list” command, it shows “starting up”. After a while it shows “off”. If I try to start it using the “services start mmq1:” command it fails (eror code 0xc00e0001). I try to register again using “MSMQADM register” command. Though this show an error :" Registry key already exists…", the next command “services start mmq1:” starts the service.

Note: mmq1: is the instance of the MSMQ service displayed by the “services list” command.

We are able to reproduce the above-mentioned steps. We are looking this and get back you soon.

Please download Svcstart services dll from here. Please keep Svcstart.dll in the FlashDisk and import the SvcStart.reg registry and Save registry.
These services will register MSMQADM after boot and then MSMQ service will be running automatically after boot.
Please let us know if you face any issue.

Hi, I am on IMX7D,
I imported the setting in the registry of SvcStart.reg, and I kept Svcstart.dll in the FlashDisk.
But MSMQ isn’t installed on my computer. It’s the message I receive when I start a program which use MSMQ. Also msmqadm isn’t installed.
Best Regards,

SYSGEN_MSMQ is not included in the iMX7 release image. Please wait for a day and we will give more details in the next reply.
Please create a new question if the issue for different Soc.

Could you please wait for 2 weeks, we will release next version of IMX7 image and binary BSP within 2 weeks. Please build a custom image with SYSGEN_MSMQ and continue your work.

Please let me know if you have any other query.