Move Component Under Other

Good afternoon Sirs,

I’m using Altium to make a PCB. And I have a problem in the positioning of some components on the printed circuit board.

I have a connector for a SOM (Colibri iMX6), and I would like to put resistors underneath this module, in the same layer - like in Iris, for example.

But Altium is not allowing you to place these resistors.

I’m dragging the component towards the connector, and when I reach the edge of it, it stops.

Is there a rule that I have not enabled, or configured incorrectly, to allow this action?

PS: Physically there is enough height for this. The resistor I use is a 0603, and there is space underneath the SOM for it.

Kind Regards,

Daniel M.

For help, i post one video in Youtube

http://www.youtube.com/watch?v=3JI5QAo0naw

Sorry for the quality.

As you can see, I can not drag into the connector.

Hello @dlmmartins,

thank you very much for using the Toradex community.

I think that the issue you are experiencing is due to the “placement mode” you have set up in Altium.

I would recommend you to have a look at this page:

http://techdocs.altium.com/display/ADOH/((Smart+Component+Placement))_AD

As you can see, by pressing the R key while doing a component placement, the tool will toggle between three placement rules:

  • Ignore Obstacles
  • Push Obstacles
  • Avoid Obstacles.
    I guess that, right now, your software is configured in the avoid obstacles mode.
    Please try to press the R button, you will see the current placement mode in the status bar which is at the bottom of the workspace.

I think that is also important to specify that Altium will use the 3D model or the copper and silk elements of your footprint to actually detect a collision. Please check this as well.
Lastly I would recommend you to check the “component Clearance” in the “placement rules” (Design->Rules):
http://techdocs.altium.com/display/ADRR/PCB_Dlg-ComponentClearanceRule_Frame((Component+Clearance))_AD

I really hope this helps, please don’t hesitate to write again if you have more issues.

Hi Daniel,

I guess the issue is related to Altium Designer 16, Smart Component Placement feature which provides 3 placement options (Ignore Obstacles , Push Obstacles, Avoid Obstacles).
For more details, please refer to the link below:
Search | Online Documentation for Altium Products)_AD

If you are not using some other version of Altium Designer, please let me know the version.

Regards,
Satyan Raj

Hi diego.tx and satyan.tx,

Really Thanks for your help.

I was able to do the way they said - via the R key - in Ignore Obstacles.

Thanks again,

Kind regards,