ModemManager on Torizon

Dear Support,
I have been working on the Imx8 mini and Verdin boards as development boards V1.1.c

I use the link below for using remote connectivity,

I did the steps successfully until the add cellular connection.

No devices were connected when I checked by nmcli c command.
In this step, I add my apn and ttyUSB [# nmcli c add type gsm ifname * con-name home apn wap.tracfone] and it was successfully added.
Do you have any ideas? Thank you so much in advance.

nmcli c

home 72b3c630-265c-4357-8f1f-bb620d4adf14 gsm –
network0 958cc5e3-1bbf-3d64-beeb-020d4414e256 ethernet –
network1 78c31df4-8c89-31a6-9aeb-d5603e230e42 ethernet –

Dear @Mehrdad,

Sorry for the delay in reaching back to you. If you’re still facing the issue, can you please share more information about your setup?

  • Are you using which Torizon version?
  • Did you check your correct APN for your cellular modem? If so could you please share the final command that you ran on the module?

wap.tracfone was a placeholder on the developer page you should change it to the one according to your device.

  • Also, which ttyUSB have you used and why?

Best regards,

Hi @gclaudino.tx ,
Thanks for your reply,

Yes, I am using Torizon core.

I add the command below
nmcli c add type gsm ifname ttyUSB1 con-name home apn
because the system’s primary port option is ttyUSB1
I can see that the response was successfully added in this step. It makes an error when using simple connect, please see the attached image.

Best regards,

Dear @Mehrdad,

Thanks for the update. Could you please share the exact Torizon Core version?

Could you please also share with us the following:

  • dmesg output in text as we can’t search through screenshots.
  • Is the nmcli c working correctly now as you went to the modem connection step?
  • Have you tried other iptypes?

Best regards,

verdin-imx8mm-07022050:~$ uname -r

nmcli doesn’t work well and the gsm doesn’t show on the Device, please see the attached image
Best regards,


As far as I understand, simple connect does not work

mmcli -m 0 --simple-connect=',ip-type=ipv4v6'

I tried ipv4 , ipv6 and also ipv4v6.

I tried disconnecting and disabling it and still have issues

Dear @Mehrdad,

Thanks for the update. I think you forgot to add the dmesg output in text format. Also, please prefer not to add screenshots but copy the text instead from command and output. This is always better for us to debug. Also please do not be afraid to post big lines of text. It’s better to have as much information as possible.

So let’s recheck the steps you took in the meantime. Can you please confirm it this was the correct order?

  1. Check that your device was available under mmcli -L
  2. Check that you have enabled the right device with mmcli -m 0 -e
  3. Check the detailed information of the device with mmcli -m 0. Also, does this information outputs more information of the device than what you sent us? Usually you should find information such as the hardware module and supported IP type. If yes, could you please share the full output with us?
  4. Check if the sim is locked. If yes, you set the pin with mmcli -i 0 --pin=YOUR_PIN_NUMBER
  5. Added the connection with something like: nmcli c add type gsm ifname ttyUSB1 con-name home apn
  6. Enabled radio switch with: nmcli r wwan on
  7. Tried using simple connect with: mmcli -m 0 --simple-connect=",ip-type=ipv4v6" or mmcli -m 0 --simple-connect="".

Could you please confirm that you have followed all the steps and also share with us all the information asked for us to properly understand what the blocking points are?

Best regards,

That’s a good point. Please see the attached text file.
The steps are the same but step 4 is before step 2.

new 1.txt (35.5 KB)

Thanks for your help.

Dear @Mehrdad,

Thanks for the logs, they provided very useful information.This error however seems a bit odd: error: couldn't connect the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.Unknown: "SM deactivation", 0, "No cause information available"'

  • Where did you get the apn-name from? Looking on the internet it seems that there are at least 3 possible apn names for vodafone on your country. Could you please try with them? Vodafone Ireland - Ireland - APN Settings.
  • Also, could you please try the command simple-connect without passing a IP type if the above didn’t help?
  • Have you tried using other SIM Cards or Modem?
  • Have you been able to use this Modem on another device such as your host computer?

new 1.txt (4.6 KB)

You are very welcome, and thanks for your help, I really appreciate it,
I tried different APNs and I found [] on the same page that you also sent. I tried with a different SIM card and also checked this modem and SIM in the M2M Proroute and it works well in the Proroute H685 WRT.

Dear @Mehrdad,

Thanks for testing with other APNs. I couldn’t find however much information on the current error you’re getting on my side. Could you please run mmcli -G DEBUG and then retry the whole procedure? This will increase the number of log messages and we may run into more useful information on what could be causing the error. Maybe we could then spot something more conclusive.

Also, could you please also try passing the pin with simple-connect with something like: mmcli -m 0 --simple-connect=“,pin=0000”?

Best regards,

new 2.txt (37.9 KB)
Thanks, Dear Support, please see the attached file,
Best regards,

The debug logs would go to system log, we need the corresponding syslog attached. See otherwise for how to launch the MM daemon in debug mode completely.

1 Like

If I’m not mistaken that output will come from +CEER, and it just says the module was deactivated normally.

I wonder if we’re breaking the connection attempt at a stage that would not require running +CEER at all. The requested debug logs would help to know that.

1 Like

Hi Aleksander,
Thanks for your help, please see the attached text.
Best regards,
debugg command.txt (212.6 KB)

Dear @Mehrdad,

Just for us to be sure, this log seems to not have the full process. Can you get another text file like that where you try the whole process from checking the device, unlocking it, enabling the modem and radio switch and then trying to connect?

Best regards,