Missing T20 Colibri config block (Colibri Evaluation Board)

Hi,

I have setup a serial console debug using Putty (baud rate of 115200, 8 data bits, no parity and one stop bit without hardware/software flow control) on Debian 6 - VMware Player virtual machine. I am trying to find out why some T20 boards do not load the operating system after flashing is complete and without any errors, while others work perfectly fine.

Small screenshot of image loading OK:
[upload|AdHEtvN5Rv8756cjjeEzZhGjFGE=]

Missing Colibri config block was listed for non-working boards:

[upload|tud4FlWKYVOvu2ohbvJ09w922SI=]

[upload|jEkpBm/zHjux1GIXgOfzkK6Xatk=]

Flashing Embedded Linux to Tegra Modules mentions erasing the whole NAND which I did (using nand erase.chip).

But the next command (cfgblock create) cannot be found:

[upload|9qTaDCXHjOGPTR7ZyAt+QhTVSN0=]

I have tried re-flashing after erasing the entire NAND. After flashing was complete successfully and Evaluation board rebooted, the same error regarding missing config block appeared on the serial debug console.

Please let me know what are the next steps.

Thanks.

You are using very old image with outdated U-Boot. Could you please download latest release from here - https://developer.toradex.com/software/linux/linux-software#Legacy_Image_Format

Sorry, but we need to use that particular image (although old) customised for our boards…
The image works fine on other T20 boards.

If you could help me please on how to fix the missing Colibri config block error, that would be much appreciated. Thanks.

In the old stable BSP V2.3 there should be a create_configblock.sh script as well as a -c argument to the update.sh script selecting configblock partition only update.

Thanks for this.

I have tried the following:

Step 1.

./update.sh -r 512 -v V1_2 . Then the Evaluation board was rebooted (holding down Recovery mode).

Step 2.

./update.sh -c -r 512 -v V1_2 which fixed the missing Colibri config block error.
Again after this, the Evaluation board was rebooted holding down Recovery mode

Step 3.

kernel updated using ./update.sh -r 512 -v V1_2 -k

No errors reported for all the above three steps.

Using the serial debug console (cutecom) and logging all the data to a file, then doing a diff on normal vs non-working case, it looks like the non-working board stopped after Initialized tegra uart driver.

Part of the diff:
[upload|P+NQRhqYAa70zk4nIUo2gS3FEZo=]

Top section zoomed in:
[upload|7tpktDjh099gpsRQeZneK/naGcU=]

Any ideas what this means?

Also is there a limit on how many times can the Colibri T20 be flashed?

Doing a NAND erase prior to Step 1 hasn’t helped. Is there anything else I need to do before flashing or can those commands (from Step 1 to Step 3) be run over and over again?

Here are the cutecom log files

So it does boot now but just hangs during boot, right? Probably just the following issue then:

https://developer.toradex.com/software/linux/linux-software/release-details?view=all&issue=20968

And yes, you may erase/flash it many times, but there is a limit to everything. The limit is somewhere in the 10 Thousand or even later, though.

Thanks.

Not sure if this is the issue.

We ordered two new Toradex boards (same ColibriT20) and this time there were no problems after the flashing has been completed (same custom made image). It was really straightforward and they worked after the first attempt.

Could it be a hardware issue? Could the other two that are not working come from a broken batch? (their SN are 10523798 and 10524174 if it helps).

Hi @choco

To check if this is an hardware issue, could you just flash Bsp 2.8b6 and check if you still see the issue on the carrier Colibri Evaluation Board.

Best regards,
Jaski

Hi,

After downloading Bsp 2.8b6, running ./update.sh -r 512 -v V1_2 -d seems to be stuck just after rcm version 0X20001:

root@guest:/home/Downloads/Colibri_T20_LinuxImageV2.3# ./update.sh -r 512 -v V1_2 -d

Colibri T20 rootfs detected

LD_LIBRARY_PATH=…/t20_nvflash …/t20_nvflash

Nvflash version 19.0041 started

rcm version 0X20001

Serial debug window is blank but the USB connections are active:

root@guest:~$ lsusb

Bus 001 Device 006: ID 0955:7820 NVidia Corp. Tegra 2 AC100 developer mode

Bus 001 Device 005: ID 0403:6001 Future Technology Devices

International, Ltd > FT232 USB-Serial (UART) IC

Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I have tried another USB port on the PC without any success.

Any suggestions please?

Kind regards.

Hi

root@guest:/home/Downloads/Colibri_T20_LinuxImageV2.3# ./update.sh -r 512 -v V1_2 -d

Are you sure, you are using Bsp 2.8?

Best regards,
Jaski

Hi,

Thanks.

Yes, sorry, I was trying to flash the wrong version :slight_smile:

I have downloaded Colibri-T20_LXDE-Image_2.8b6.184-20190401.tar.bz2 and I will retry.

Kind regards.

You are welcome. Please let us know your results.

Best regards,
Jaski

Hi,

The following error with ./tegrarcm: error initializing miniloader: Resource temporarily unavailable returns:

root@guest-VirtualBox:/home/corina/Downloads/Colibri-T20_LXDE-Image_2.8.6# ./update.sh -d -r 512 -v V1_2

Colibri T20 rootfs detected

bct file: …/colibri-t20_bin/colibri_t20-512-v12-nand.bct

bootloader file: …/colibri-t20_bin/u-boot-dtb-tegra.bin

load addr 0x80108000

entry addr 0x80108000

device id: 0x7820

uid: 0x021ca14542a05317

RCM version: 2.1

downloading miniloader to target at address 0x40008000 (132976 bytes)…

Error downloading miniloader

./tegrarcm: error initializing miniloader: Resource temporarily unavailable

I am using X29 with a USB A to USB B cable and the module is in recovery mode.

dmesg displays:

[31804.055737] usb 1-2: new full-speed USB device number 15 using ohci-pci

[31804.546926] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x81 has

invalid maxpacket 512, setting to 64

[31804.546931] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x1 has

invalid maxpacket 512, setting to 64

[31804.568683] usb 1-2: New USB device found, idVendor=0955,

idProduct=7820

[31804.568693] usb 1-2: New USB device strings: Mfr=1, Product=2,

SerialNumber=0

[31804.568699] usb 1-2: Product: APX

[31804.568705] usb 1-2: Manufacturer: NVIDIA Corp.

I have tried another USB port on the PC without success.

Both Colibri T20 report the same issue.

Any suggestions please?

Kind regards.

Hi @jaski.tx

That’s great. Thank you.

Kind regards.

You are welcome.

Best regards,
Jaski

HI @choco

A responsible of Toradex will contact you by E-Mail and give you instructions how you can the non-working modules back to Toradex. Once we got the modules, we can examine them and find the root cause of the error.

Best regards,
Jaski