Missing information in "FreeRTOS on the Cortex-M4 of a Colibri VF61" document

This kb document describes how to load and run a M4 application from A5 core on VF61.
The section Demo with prebuilt M4 binary in Revision 19 - 11 Mar 2017 states:

  1. Download Toradex CE Library V1.9 or higher and build Rpmsg_Demo application.
  2. Run Rpmsg_Demo.exe application along with rpmgsp_pingpong_example.bin

Since the libraries are valid for multiple devices, rpmgsp_pingpong_example.bin is not included in the library.
From the documentation, it’s not clear where to download this binary and where to copy it, since inside Rpmdg_Demo.c files there is a comment saying

//rpmsg_pingpong_example.bin file will be copied to the FlashDisk automatically when deploying it.

and this is true only if the .bin file is copied in a specific folder inside libdemos folder.

I think it’s better to clarify a little bit how to proceed to run the example as expected.

@vix, Thank you for pointing out missed information.The rpmsg_pingpong_example.bin firmware file is missed in V1.9 Toradex CE library release. Please download the firmware file from here. This problem will be solved in next version V2.0 release.

@raja.tx, 've just downloaded V2.0 Toradex CE library release: the rpmsg_pingpong_example.bin firmware file is included in the package but the deployment from VS2008 fails.
Under “project properties” >> “Configuration Properties” >> “Deployment” >> “Additional files” I see


and this should follow the syntax

<filename>|<source directory>|<remote directory>|<register, 1 or 0>

The deployment fails because rpmsg_pingpong_example.bin cannot be found.
The working setting is


at least on my PC with Win7 and VS2008.

Moreover, the “Remote Directory” for deployment is set to \FlashDisk, but “project properties” >> “Configuration Properties” >> “Debugging” >> “Remote Executable” is set to


which is not under \FlashDisk.
If the setup for remote directory is right, this should be


We fixed many things in property sheets that way it works for us. We are delivering the same package for the release. Maybe your case, you are not using our Library release structure. In that case, this fix may be needed for you. Thank you for letting us know.
Thank you for reporting Remote Executable path not proper. It will be corrected in next release.

@raja.tx, I use exactly your Library release structure. I downloaded the library as a zip file and I extracted on my PC.
I didn’t move or copy any file.

You found the solution and thank you for posting here. We will check at our side, if there is an issue it will be corrected.