Migrating from WEC7 to WEC2013

Hi community,
we are considering to migrate our project that was built under SDK 2 winCE7 to Windows Embedded 2013.
As far as we can understand, we have to install a newer version of Visual Studio (2013) and a newer SDK (Toradex_CE800).
Problems began when we tried to migrate Visual studio .sln since the automated process failed because the old sdk isn’t available on Visual studio 2013 (and the newer isn’t available in VS 2008).
Is there a way we can do this without recreating the whole solution from scratch?

It is correct you have to use either VS2013 or VS2015.

Unfortunately, there is no straight forward path do an automated migration.

I two possible option to do a migration.

  • Create a backup of the project. Search for SDK2wince7 (ARMv4I) and replace it with “Toradex_CE800” in all *.sln and *.vcproj files. After that you should be able to migrate. Still after that you may have to tweak some project settings that are not valid any longer in order to be able to build the project.
  • Create a new WEC2013 project in VS2013 / 2015 and manually migrate the settings. May be this also will help you to understand what configs may does not match if you migrated with the first option above.

If anyone in the community has an easier way to get that done, please share let us know.

The first solution doesn’t work for us so we have manually migrated projects settings.
Now we are facing a different issue: we have an embedded player in our application based on DirectShow technology. Trying to debug it, we have noticed that also mediaplayer in \Windows folder is not working (Player.exe is not a valid Windows Embedded Compact application"). We saw that there is an open issue on that and we are wondering if it is due to a common problem on the underlying layer (codecs? directshow?). Could you please give us further information?

The default ImageViewer is not working too, it has a broken link. We haven’t found any open issue on the release roadmap.

This was an issue with image 1.4 due to a error while building the image. A player for CE 7 was used which is not binary compatible. You can either use image 2.0beta1 or get the player.exe from the 2.0b1 BSP, this one should work.

The image viewer is currently not supported, the API has changed, so we can not just compile that for CE 8. We have removed the broken link in 2.0 beta 1.

Hi samuel, i’ve downloaded and installed version 2 beta 2. Now I can open the media player but it seems that it doesn’t work (black screen). I’ve tried with .mpeg and .avi files.
With .mpeg ones the video is displayed only after the media player window is transleted while playing the video.
Am I missing somenthing?

UPDATE: given the problems on the pre-compiled image, we have tryed to build a custom image starting from the workspace and bsp provided by you for v2beta2 and we have checked the presence of the catalogs concerning the desired codecs.

During the build we noticed a series of warning messages like the following one:

EXEC : warning : Unable to do imports from libnvomx.dll to libnvmmlite.dll - will late bind [C:\WINCE800\public\common\oak\misc\makeimg.proj] {log=“C:\WINCE800\build.log(29899)”}

We have not idea if this could be related to our problem but googling a little around this, it seems that the dll is involved in codec support.

@samuel.tx can you confirm me that video codecs are working correctly in the version 2 beta 2?

@lerimini: I will quickly cross check, if the supported codecs run fine.

The build warings are fine, this is not an issue, for video playback, there is no need to build a custom image. Please be aware that not all codes are supported. You find a list of supported codecs on the this Nvidia Website. Note: CABAC on h264 are not supported.

Hi @samuel.tx and thanx for your support.
Our video are MPEG-4 and they were correctly displayed under ce7 bsp1.4.
With pre-compiled ce2013 bsp2.0 beta2 we are not able to see them in our application (DirectShow) and ALSO using the MediaPlayer you provide. The same for some samples downloaded from the web, like the attached one.
Could you please give a try with this one?[link text][1]
[1]: https://share.toradex.com/qy28z736zbw20sl?direct

We have tried also with MPEG2, but no way…we are able only to play .mpeg files (MPEG1). In this case our application works fine but the mediaplayer needs to be moved while playing to get something shown.
Thanks in advance.

@lerimini: Thanks, was not aware same videos have been working in 1.4 CE 7. I will give it a try and get back to you.

Hello @lerimini.

I have tested you with the video you have shared.

How I have tested:

  • Flashed a standard image WEC2013 V2.0 beta 2 on a Colibri T30 using recovery mode / NVFlash
  • Put the video you sent us on a USB Memory device
  • Booted the device, inserted the USB Memory device
  • Double clicked the video

Result: The video played well. Please try once with the standard image. One note: The full screen mode did not work. We are currently checking that an there will be an issue added on our road map about that.

Note about Colibri T20 / T30: Colibri T20 is officially not supporting WEC 2013 as this actually uses more floating point registers. Basically it runs there as well, but this is a requirement from MS we can not warrant that it runs in all use cases.

Followed your steps and the problem disappeared. Probably we made some mistake in the update process. Sorry & thanks for support.