MCUXpresso examples don't work

Good morning,

My company bougth the following setup:

Toradex employee suggested that I should use MCUXpresso SDK and use the SDK “MIMX8QM6xxxFF” (I used the GCC ARM Embedded toolchain)for the projects I do with this module. The problem is that although I’m able to compile the “hello world” project with the scripts provided by the SDK and then I followed the guide (High performance, low power Embedded Computing Systems | Toradex Developer Center) step by step to run the project and I observe no result at all.

I checked connections, jumpers, if the bin file was on the SD card from U-boot, everything, and I saw nothing on my console connected through the RS232-USB cable.

I was able to load the bin image like you said, but again, nothing happened. I tried for both cores (0 and 1) with its correspondent connections and still nothing.

I’m really puzzled here, because I’ve been almost two weeks trying to make a simple “hello world” to work on my module and I’m not able to do it and the guides that are available on Toradex’s and NPX’s pages seem not to be as helpful as I desire, so I really need help on this.

Could it be that this module is not supported by the MCUXpresso SDK? Because when I download the SDK for “MIMX8QM6xxxFF” the only board that shows is the “mekmimx8qm” model so could it be that the example I run, is not designed for my module/board?

I really don’t know what to think because I tried a lot of stuff and nothing seem to work, and it’s really annoying and frustrating.

Maybe if you have a video tutorial or guide with step by step programming and loading an example on my actual module and board would help me on that.

Looking forward to hearing from you.

Best regards,


Greetings @juanigevo!

We’re currently working on testing and better documenting the heterogeneous multicore processing functions on our latest BSPs. We’re aware some examples are not working and some issues are already being escalated properly.

However, the hello world example should work. Did you try following the instructions on this page: FreeRTOS on the Cortex-M4s of a Apalis iMX8 | Toradex Developer Center?

I’ll also try reproducing your setup here and let you know my results.

Hello Gustavo,
Yes, as I mentioned above I followed step by step your instructions, but couldn’t make it work.
I’m attaching my setup, and connections for you to see if I’m doing something wrong as regards as connections.
alt text

Looking forward to your reply.

Hello @juanigevo!

I was able to run the Hello World example on the M4 core 0 on the Apalis iMX8. I’ve followed the instructions here, but I made sure to update the article a bit.
Here’s a quick gif of the running application (note that I loaded the firmware from TFTP instead of from an SD card, but this shouldn’t make a difference): Imgur: The magic of the Internet (sorry, our forum backend does not allow for embedding gifs).

I also noticed your wiring looks a little bit different than mine. Here’s my jumper setup for using the M4_0 UART:

This routes the pins to the X28 top connector, like this:

I’ve also uploaded the firmware I used for testing this, just in case:

Let me know if you’re able to reproduce my results.

Hello Gustavo,
I’ve followed all steps on the guide you sent me. Changed the jumper’s position to match exactly as yours. I even downloaded the example from the link you sent me but still I’m not able to make it work.
I’m attaching a couple of images regarding the serial connection and the steps I followed.
One thing I could notice that happens in your gif is that the connection to the M4 has some lines written which seems to be configurations or commands whereas in my console, nothing happens, not even when I powercycle the board.
I’m trying to reproduce the exact same configuration as yours but somehow I can’t manage to make it work.
The SD is formatted in FAT format, could that be causing this issue?
link text


A FAT-formatted SD card should work. I’ll try to find an SD card around here and try to reproduce the steps. I’ll let you know as soon as I have any results.