Mallow AM62 Recovery script failed


After building for the first time my light custom image ( no modification for this first try), i try to deploy it but i meet issue: There is some ssh connexion error. I precise that i’m able to connect via root@ Then i decided to reinstall Tezi but i after download by USB OTG, message indicated a fail.

Noe that i set the correct driver universal Serial driver. When i connect the usb cable after recovery hardware sequence, i clearly see the AM62. Then i run the script and i see that it download a first time properly. Then i hear a kind of usb disconnexion, and the board re appear in the peripheral list no more as AM62 but as USB gadget. It continue to download whith some strange error like :

Failed to retrieve string descriptor 4
Failed to retrieve string descriptor 5
Failed to retrieve language identifiers
Failed to retrieve language identifiers

Here all my process from unboxing my Am62 + Mallow board to now:

  1. First power on
  2. Connexion with RealVNC to Tezi and install Torizon OS multimedia image
  3. Install Tool on WSL2
  4. Build simple image
  5. Fail to deploy → Need to recovery and install Tezi removed by Step 2) ?
  6. Let’s try to go to recovery mode ( 10sec min with jumper, remove jumper, run recovery-windows.bat)
  7. Seems to have download stuff but fail message at the end
  8. Try to deploy via ssh again, same fail:
flo@florian-fixe:~/tcbdir/imagesBuild$ torizoncore-builder --verbose deploy --remote-host --remote-username torizon --remote-password torizon --reboot
2024-01-22 12:55:41,642 - torizon.tcbuilder.backend.deploy - INFO - Pulling OSTree with ref base (checksum 5d84f30579bf5a58fbbf71602b008aa8ea221f479da6dcc54387c191199c87fd) from local archive repository...
2024-01-22 12:55:41,643 - torizon.tcbuilder.backend.ostree - INFO - Starting http server to serve OSTree.
2024-01-22 12:55:41,643 - torizon.tcbuilder.backend.deploy - INFO - OSTree server listening on "localhost:38279".
2024-01-22 12:55:44,380 - root - CRITICAL - An unexpected Exception occurred. Please provide the following stack trace to
the Toradex TorizonCore support team:

2024-01-22 12:55:44,381 - root - ERROR - Traceback (most recent call last):
  File "/builder/torizoncore-builder", line 221, in <module>
  File "/builder/tcbuilder/cli/", line 101, in do_deploy
  File "/builder/tcbuilder/cli/", line 92, in do_deploy_ostree_remote
    dbe.deploy_ostree_remote(args.remote_host, args.remote_username,
  File "/builder/tcbuilder/backend/", line 294, in deploy_ostree_remote
  File "/usr/lib/python3/dist-packages/paramiko/", line 368, in connect
    raise NoValidConnectionsError(errors)
paramiko.ssh_exception.NoValidConnectionsError: [Errno None] Unable to connect to port 22 on

Note that i tried to run the linux sheel cript to recover but it just print :

flo@florian-fixe:~/tcbdir/tezi/Verdin-AM62_ToradexEasyInstaller_6.5.0+build.4$ sudo sh
Install or update dfu-util from your distro should the provided one not work with your distro

Hi FloSolio,

The new recovery-script for AM62 apart from dfu, also use uuu tool to use Fastboot protocol to download the kernel image faster. On Windows, sometimes you need to install ADB driver for USB Download for Fastboot to work or Windows try to use an incorrect driver. On [1] there are some tips on how to do this.


João Paulo


Thanks a lot for your fast reply !

I just change the driver by the one on top of WinUSB ( ADB) and i worked directly !

Now i have to understand why i can’t deploy the image by ssh

Hi @FloSolio,

I see that on your deployment command you are using password torizon. After the first login onto you will be forced to change the password.

Can you try to do that and then change your command to include the new password you set?

One more question, just to clarify. The module is already running Torizon OS when you try to ssh deploy right?

Let me know if that changes anything.

Best Regards

Hi Kevin,

At the moment, The module runs the Toradex Embedeed Linux with multimedia image that where originally into the Tezi at first power on. I installed it just to test.
Now, i try the online documentation to simply build a custom image based on official OS Torizon v6 for am62 image.
I succesfully build it, but i’m not able to deploy yet.
I thought that my custom image have been built for tezi, and , because my first OS instal, Tezi has been removed.
So i decided to flash Tezi again after recovery hardware sequence.
After succeding to flash Tezi via usb with windows only one time (adb driver), i tried again to deploy with torizon-builder but same ssh issue…
Note that i was able only one time to load Tezi by usb with windows… I quicky jumped to a Ubuntu VM linux and runs the script and it worked directly without to play with driver etc…

Concerning password, i always connect as root@ and i don’t use password.

Concerning Toriez user name and password, i have just used that to follow the tutorial, thinking that, by default, Tezi was accepting this.

But it seems i’m confused by the work flow. Should I really follow this sequence to deploy the custom image: recovery hardware sequence / usb otg / torizon-builder deploy / VNC session for Tezi and select custom images to install ?

Here is what i have today when i’m connected to the SOM after recovery sequence:

As you see, Tezi is not asking to install my custom image but the one by default i guess.

Hi @FloSolio ,

would you be willing to jump in a call with me? So that we can get rid of the confusion?

If yes, then I’ll send you a personal message.

Best Regards

Yes sure ! Thank you !

1 Like