LXDE 2.8 with QT5.13 on Apalis IMX6


I build the newest toradex lxde 2.8b6 image.
Now I tried to include the meta-qt5 layer. The standard QT5.9.8 version from the toradex repository builds without problems.

But I need a newer version of QT, the version QT5.13.
So I replaced the standard QT5 layer of the toradex repository with a newer version from the openembedded repository.

The only thing is, that the newer meta-qt5 layer do not support linux “rocko” from the toradex 2.8b6 build.
So I have to change somethings on the meta-qt5 layer:

  • add “rocko” to the local.conf
  • remove the qwebkit from the packagegroup, because here are to much changes

The only thing that has been changed from QT5.9 to QT5.13 is the XCB driver. They changed from xinput2 to xcb-input.

So there is only the error with:
“ERROR: Feature ‘xcb-xinput’ was enabled, but the pre-condition ‘!features.system-xcb || libs.xcb_xinput’ failed”


| Using system-provided XCB libraries … yes

| EGL on X11 … yes

| XCB XKB … yes

| XLib … yes

| XCB render … yes

| XCB GLX … yes

| XCB XInput … no

| XCB Xlib … yes

| Using system-provided xkbcommon … yes

Could someone help me to solve this problem?
Here are some more infos about the qt requirements: Qt for X11 Requirements | Qt 5.15


Hi @jtronics and Welcome to the Toradex Community!

Unfortunately, Qt has major dependencies to many another thing, mixing and matching Qt version is not easily possible. I’m wondering why exactly do you want to have the version 5.13 of Qt?

You can build a custom image with Bsp 3.0 using the command bitbake -k qt5-x11-image. Maybe it is easier to update to Qt 5.13 with the newer kernel.

Best regards,