LVDS 10.1 " capacitive touch display problem

I have the following question: I am trying to use a 10.1"" touch
display (capacitive) with a iMX8 module on a Apalis evaluation board
under TorizonCore (image created 1.6.2021 & downloaded by Easyinstaller).

However, it displays nothing. The backlight seems to work.
Also the main HDMI display is dark. Still, the module is up and running,
and it is possible to log in from the network.

I have been following the recommendations at:

I have tried to use a pre-built Device Tree Overlay:

apalis-imx8-06805164:/sysroot/boot/ostree/torizon-cad4230bb4cbaa931d36a90bd375a75fa3291d66311587ba799a563a81464ae0/dtb$ ls -l 
total 648
-rw-r--r-- 1 root root 162699 Jan  1  1970 imx8qm-apalis-eval.dtb
-rw-r--r-- 1 root root 163637 Jan  1  1970 imx8qm-apalis-ixora-v1.1.dtb
-rw-r--r-- 1 root root 162801 Jan  1  1970 imx8qm-apalis-v1.1-eval.dtb
-rw-r--r-- 1 root root 163659 Jan  1  1970 imx8qm-apalis-v1.1-ixora-v1.1.dtb
drwxr-xr-x 2 root root   4096 Jan  6 13:31 overlays
-rw-r--r-- 1 root root     43 Jun  6 15:44 overlays.txt
apalis-imx8-06805164:/sysroot/boot/ostree/torizon-cad4230bb4cbaa931d36a90bd375a75fa3291d66311587ba799a563a81464ae0/dtb$ ls -l overlays     
total 60
-rw-r--r-- 1 root root 3497 Jan  1  1970 apalis-imx8_ar0521_overlay.dtbo
-rw-r--r-- 1 root root  402 Jan  1  1970 apalis-imx8_atmel-mxt_overlay.dtbo
-rw-r--r-- 1 root root  638 Jan  1  1970 apalis-imx8_lvds_overlay.dtbo
-rw-r--r-- 1 root root 2503 Jan  1  1970 apalis-imx8_ov5640-2_overlay.dtbo
-rw-r--r-- 1 root root 2188 Jan  1  1970 apalis-imx8_ov5640_overlay.dtbo
-rw-r--r-- 1 root root 1377 Jan  1  1970 apalis-imx8x_ad7879_overlay.dtbo
-rw-r--r-- 1 root root 1097 Jan  1  1970 apalis-imx8x_atmel-mxt_overlay.dtbo
-rw-r--r-- 1 root root 1055 Jan  1  1970 apalis-imx8x_lvds_overlay.dtbo
-rw-r--r-- 1 root root 1546 Jan  1  1970 apalis-imx8x_parallel-rgb_overlay.dtbo
-rw-r--r-- 1 root root  820 Jan  1  1970 display-dpi-lt170410_overlay.dtbo
-rw-r--r-- 1 root root  803 Jan  1  1970 display-edt5.7_overlay.dtbo
-rw-r--r-- 1 root root  803 Jan  1  1970 display-edt7_overlay.dtbo
-rw-r--r-- 1 root root  835 Jan  1  1970 display-fullhd_overlay.dtbo
-rw-r--r-- 1 root root  835 Jan  1  1970 display-lt161010_overlay.dtbo
-rw-r--r-- 1 root root  854 Jan  1  1970 display-lt170410_overlay.dtbo
apalis-imx8-06805164:/sysroot/boot/ostree/torizon-cad4230bb4cbaa931d36a90bd375a75fa3291d66311587ba799a563a81464ae0/dtb$ cat < overlays.txt 

Dmesg gives:

apalis-imx8-06805164:/var/log$ dmesg | grep -i lvds
[    1.540820] imx-drm display-subsystem: parent device of /bus@57240000/ldb@572410e0/lvds-channel@0 is not available
[    2.270344] debugfs: Directory 'lvds1' with parent 'pm_genpd' already present!

So, any ideas where to start looking ?


A couple of pictures of the connections:

Hi, @Pernillux

From your overlay listing, there are some dtbo files missing.

Please, take a look here to see which overlays you need to apply in order to use the 10.1" LVDS display: Device Tree Overlays on Torizon | Toradex Developer Center

You’ll see that fo Apalis IMX8 (not the IMX8X), you need:

  • apalis-imx8_lvds_overlay.dtbo,
  • apalis-imx8_atmel-mxt_overlay.dtbo,
  • display-lt170410_overlay.dtbo

Let me know if this solves your problem.

Best regards.

Hello, yes, this certainly moved things a lot forward, many thanks ! I read the List of Device Tree Overlays wrong, assuming that the text ‘Capacitive Touch Adapter’ was a possible extra option only.

But one peculiar problem remains: I can move my application onto the touch screen from my main HDMI-connected screen (using the main screen mouse). BUT when I touch the touch screen screen, it only affects the main HDMI-connected screen ! I can move and zoom the picture on the HDMI-connected screen from the touch screen, but the touch screen itself remain unaffected :smiley: So, some parameter somewhere probably wrong ? I could also in principle skip the main screen, it will not be used in the final application…

Hi, @Pernillux

Just to explain better:

  • apalis-imx8_lvds_overlay.dtbo: this one “enables” you to use the LVDS
  • apalis-imx8_atmel-mxt_overlay.dtbo: this one makes the touch work (you also need the driver for the touch, but it is already available)
  • display-lt170410_overlay.dtbo: specific display settings for the 10.1" Capacitive LVDS Display from Toradex webshop

About the odd behavior between the touch and the screens, I have never tested it, but I would say that this is configurable in the weston.ini file (weston.ini(5) — Arch manual pages).

There is the seat property on the output section. Here is an official explanation of what is seat: Running Weston — weston 11.0.90 documentation

You can try to attach the touch seat of the LVDS output.

I simply disconnected the main HDMI screen, leaving only the smaller touch screen, which now works correctly (touches hitting correct buttons). Thanks for all help !

Hi @Pernillux

Perfect that the issue is solved. Thanks for the feedback.

Best regards,