Login new user error message - Systemd-journald[74]: Failed to read ACL

I have a Colibri vf50 module running linux V2.5 on a custom board with two LAN ports.
I have added a new user “admin” with a home directory of “/tmp/admin” via Yocto ( I only want the user to have access to temporary storage). However, when the user logs in via SSH, I get the following message reported to the system journal:

[ 1821.534714] systemd-journald[74]: Failed to read ACL on /var/log/journal/022f6f0f08254bba9a2cddc5b49b248d/user-1200.journal, ignoring: Operation not supported

Any idea what may be causing this?

It seems to be related to ACL (Access Control Lists). Systemd supports Posix ACL’s and tries to read them for that specific file. Unfortunately the file system we are using on Colibri VF50 (UBIFS) does not support Posix ACL’s.

I wouldn’t expect operational issues with the message (other than no ACL support), it has more informational character…

As far as I know systemd allows to compile without ACL support, I guess if you build a systemd with ACL disabled the message would disappear. However the systemd OpenEmbedded recipes seems not to have a packageconfig for it.

Hello, I have the same error message with Colibri imx6d module, as UBIFS seems to be the file system.
Is there a way to remove the error? (My boss is not happy to see error log, even if it is not causing issues…)

Why is the error not present when logging with root? Is not the problem just a permission error?

Note that Colibri iMX6D does not use UBIFS, but ext3 file system. The ext3 file system has POSIX ACL support and our stock kernel enable it by default.

I quickly tried to reproduce the issue on a Colibri iMX6, logged in with a non-root user via SSH, but it did not show the mentioned error. What version of the Toradex BSP are you using?

The main components version are:
I do not know if it change something to the error, but I try to connect directly on board with debug terminal, not in ssh

Oups, I’m not working on iMX6 but iMX7!!

Colibri iMX7 makes use of UBIFS, and Linux 4.1 which comes with the current BSP does not support ACL yet.

You can get rid of the message by recompiling systemd without ACL support (configure with --disable-acl). The proper way would be to add PACKAGECONFIG support for the systemd recipe.

PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"

You can also just add a bbappend for systemd in a higher layer and use EXTRA_OECONF:

EXTRA_OECONF += " --disable-acl"