Loading Toradex easy installer from External Media (SD Card/USB Stick)


We are using a custom carrier board with apalis SOM. We don’t have a options to enter recovery mode using USB interface. So we are trying to load roadex easy installer using external media (SD card / USB).

I followed instructions from the URL: Loading Toradex Easy Installer | Toradex Developer Center

I copied the easy installer into a USB drive (FAT format) and renamed the boot script to boot.scr.
I ran the boot command (run bootcmd_usb0) from the uboot terminal to launch the easy installer. but I get the error message saying unknown "hdp"command

Can someone help me to load easy installer from external media.

U-Boot 2022.04-6.5.0+git.28dc906f6107 (Jan 01 1970 - 00:00:00 +0000)

CPU: NXP i.MX8QM RevB A53 at 1200 MHz at 45C

Core: 194 devices, 20 uclasses, devicetree: separate
Loading Environment from MMC… OK
In: serial
Out: serial
Err: serial
Model: Toradex 0048 Apalis iMX8QP 2GB WB V1.1C
Serial#: 07107212


  • SCFW 6638c032, SECO-FW c9de51c0, IMX-MKIMAGE 3bfcfccb, ATF 3c1583b
  • U-Boot 2022.04-6.5.0+git.28dc906f6107

flash target is MMC:0
Net: eth0: ethernet@5b040000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
Apalis iMX8 #
Apalis iMX8 #
Apalis iMX8 # run bootcmd_usb0
starting USB…
Bus usb@5b0d0000: USB EHCI 1.00
Bus usbh3: XHCI-imx8 init hccr 0x000000005b130000 and hcor 0x000000005b130080 hc_length 128
Register 2000820 NbrPorts 2
Starting the controller
scanning bus usb@5b0d0000 for devices… 1 USB Device(s) found
scanning bus usbh3 for devices… cannot reset port 1!?
2 USB Device(s) found
scanning usb for storage devices… 1 Storage Device(s) found

Device 0: Vendor: SanDisk Rev: 1.00 Prod: Ultra
Type: Removable Hard Disk
Capacity: 14955.7 MB = 14.6 GB (30629376 x 512)
… is now current device
Scanning usb 0:1…
Found U-Boot script /boot.scr
3260 bytes read in 4 ms (795.9 KiB/s)

Executing script at 9d480000

43 bytes read in 4 ms (9.8 KiB/s)
106496 bytes read in 4 ms (25.4 MiB/s)
Unknown command ‘hdp’ - try ‘help’
SCRIPT FAILED: continuing…
Apalis iMX8 #


Hi @Dhanyakumar ,

Thanks for posting your query to Toradex community.

Regarding your query I hope you are aware that this is not recommended way to flash image and working of this method may or may not be supported in future.

Regarding issue can you please share which version of Toradex Easy installer you are testing, additionally can you test loading Toradex easy installer with Toradex carrier board and check there also you are facing same issue.

Best Regards
Ritesh kumar

Thank you for your response. Yes we are aware that its not recommended way, but we need this option to reprogram boards as part of production process using external USB or SD Card. I am yet to try on toradex carrier board, will let you know the how it behaves on it.

I was able to reload easy installer using SD card all these days and program our customized yocto generated image.

Yesterday for the first time I programmed torizon (with containers) image, post that I am not able to load easy installer using SD card or USB.

I am using TEZ version 5.7.5.


Hi @Dhanyakumar,

Thanks for sharing details. Can you also please share Torizon OS version flashed, if you have flashed Torizon 6 or above please download one of nightly build for Toradex easy installer version 6 and check.


Best Regards
Ritesh Kumar


I have programmed custom image generated by torizon core-builder tool. I used torizon-core-docker-apalis-imx8-Tezi_6.5.0+build.8.tar as base image and bundled with docker container to generate custom image. (Used Weston docker compose example file given in toradex website.

I am not able to reprogram board using torizon core builder deploy command. I see successful message after executing deploy command, but old image comes up after rebooting. browser URL is different in two image versions, so I am sure that it’s still old image.

Command that I used to deploy new custom image on to board.

torizoncore-builder deploy --remote-host --remote-username torizon --remote-password torizon --reboot


Hi @Dhanyakumar,

Please create new community ticket in future if topic/issue changes. This help us maintain sanity of information with respect to primary question.

Regarding deploy command when image is pre-provisioned with containers then ssh deploy will not work. You will need to generate Toradex easy installer compatible image first and flash using image to module using Toradex easy installer.

Please refer below links for details

Best Regards
Ritesh Kumar


I have tested it on the Toradex EVAL board (ixora carrier) and I still see the same behavior.
i.e. unable to load easy installer from SD card / USB drive.

Please consider a scenario in which we need to reprogram the boards at the factory.
we can’t ask factory people to follow recovery steps to bring up EazyInstaller. Instead simple procedure using a USB/SD Card will work better


Hi @Dhanyakumar ,
New module comespre-flashed with Toradex Easy Installer so you do not have to load Toradex easy installer again. In this case just do the below steps
a. Copy image to USB/SD card.
b. Edit image.json file to
“autoinstall”: true,
c. Attach your pendrive/SD card to the board and your image will be automatically flashed.

Lets assume another scenario where the module does not have Toradex Easy Installer preflashed then you can simple use external media(USB/SD card) to load it and then flash your image.
Make sure if you are using image version 6 and above use Toradex easy installer version 6. I just now tested and it worked without any issue, see logs
I request you to first try flashing with default Toradex images not with your customized image
For “deploy” comand throwing error, please open another post.