LinuxImage V2.8 BSP compile error on colibri-imx7

I am getting compile error on LinuxImageV2.8 when building the console image:

bitbake console-tdx-image

Trying bitbake angstrom-lxde-image also gives the same errors.

Apparently, there is some issue in compiling imx-loader-native where usb-1.0 library cannot be found. I have attached the bitbake output log output and related log.do_compile for more info.

The only configuration I have done is the following in the local.conf which should be irrelevant:

BB_NUMBER_THREADS = "12"
SDKMACHINE = "i686"
DL_DIR = "/opt/yocto/downloads/"
RM_OLD_IMAGE = "1"
MACHINE ?= "colibri-imx7"

I’ve tried repo sync to make sure I have the latest sources, but that didn’t help.

And you did install the pre-requisites as explained here?

I had some missing packages (specifically libusb-devel.i686 and libuuid-devel.i686) on my host system. Following instructions in this link solved the issue:

https://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)#Prerequisites

I did not. My bad. Installing them fixed this issue, thanks. We had built yocto images before on this server and I didn’t expect any missing prerequisites.

This really has to do with our legacy image packaging which includes certain 32-bit versions of host tools to be used for target recovery.

Another issue: Now I am getting errors with pattern of The recipe XX is trying to install files into a shared area when those files already exist where XX is base-files, volatile-binds, update-rc.d, shadow-securetty, etc, on a scratch bitbake console-tdx-image. Should I open a separate question?

Yes, please. Also don’t forget to mention should you have any local.conf modifications or such.