Linux x-window-manager does not take care of evdev conf

I noticed that graphical application started through x-window-manager script/service does not take care of X11 custom configuration.

I’ve edited :


To invert y axis coordinates for example ( Qt5 widget app works inverted with no chance to swap y coordinates even through tslib…)

And i use to hide mouse /touch pointer for example starting X from terminal :

X -nocursor &

If i bind x-window-manger script to start my custom qt app there’s no way to get inverted y axis as if this way evdev customization does not apply to X session.

Xorg-input-evdev is a thing of the past and got superseded by libinput. Therefore, you need to use a libinput calibration matrix instead.

Sure, i am aware of xinput set-int-prop
and it works as expected for axis inversion.
But still /etc/pointercal.xinput seems ignored by app autostart through service /etc/X11/Xsession.d/ while it’s loaded cleanly through terminal invocation of X.

Have you tried our regular LXDE based demo images? Does it work there? Yes? OK, good. Well, then it might just have to do with whatever exactly you did customise or are doing, isn’t it? Unfortunately, I missed the exact how, what and why that is. Could you please maybe elaborate from the beginning what exactly it is that you are trying to achieve?

I am working on regular angstrom-qt5-x11-image , due to the fact Qt widget app revert y axis ( upside down ) X11 easely helps in this through the option :

Section "InputClass"
Identifier "evdev touchscreen catchall"
MatchIsTouchscreen "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
Option "InvertY" "true" <-this one

…but starting automatically my app through the x-window-manager service does not take care neither of xorg.conf ( and related scripts ) customizations nor of xinput set-int-prop action…therefore any Qt app( even qtsmarthome demo ) starts with reverted y axis !

Dear @Debbio

Can you once try to run Xorg manually?

systemctl stop xserver-nodm
# ignore the error
Xorg -config /etc/X11/xorg.conf &> /tmp/xorg.log &
cd /usr/share/qtsmarthome-1.0/

After that please check the /tmp/xorg.log file if /etc/X11/xorg.conf is loaded correctly and it used the correct /usr/share/X11/xorg.conf.d. If this works the you may have to tweak /etc/default/xerver-nodm.

If this doesn’t help maybe you find a problem in the /var/log/Xorg.0.log logfile?


that’s the service i was looking for, i will tweak the script !

You are welcome. Let us know if this works.