Linux kernel fetch failure

We successfully setup a Yocto based build for the Verdin iMX8MM platform. However, we frequently run into an issue where BitBake is unable to fetch the linux-toradex-5.15.77 from Toradex servers:

ERROR: linux-toradex-5.15.77+gitAUTOINC+95b4e4bb8a-r0 do_fetch: Bitbake Fetcher Error: FetchError('Unable to fetch URL from any source.', 'git://;protocol=https;branch=toradex_5.15-2.1.x-imx;name=machine')

The fetch gets triggered by the meta-toradex-nxp/recipes-kernel/linux/ recipe. We’re on commit 0dc187478a0d363683a6c5ba59b042e56aa87e81 of the corresponding meta-toradex-nxp repository.

This issue has been plaguing us for well over a week now. Just re-running BitBake several times eventually succeeds. Sometimes it works on the 2nd try, sometimes it works later the same day, sometimes it takes a day or two.

As we didn’t modify anything in/of the meta-toradex-nxp repository and as the issue “resolves itself eventually” we’re believing that this is not necessarily something that is wrong on our end. Furthermore, we’re experiencing the same issue when working on/from different networks.

Is there something we’re missing, an additional setup or configuration we’re lacking or is this an issue on the Toradex infrastructure side of things?

Hello @jbo,

Thanks for reporting this error.

It looks like for some reason the bitbake is not able to fetch the linux-toradex repository under certain circumstances that we don’t know for sure at the moment. As you already mentioned, the problem is not on your side. I will report this internally and will update you regarding any news.

For the time being, you can work around this issue with an “ugly” hack:

You can manually create the missing files in the oe-core/downloads/git2 directory. To be specific, these are the commands that you should be executing:

rudhi@nb:~/oe-core/downloads/git2$ git clone --bare git://
rudhi@nb:~/oe-core/downloads/git2$ touch

After this, the bitbake command should work just fine. Please let me know if that helps :slight_smile:

Hello @jbo,

Have you been able to solve this issue using the workaround?

Sorry for the late response - I was tied up in other projects.
Yes, we were eventually able to build by doing pretty much what you outlined, @rudhi.tx

We also noticed that the original issue we reported here seems to have a somewhat “strange behavior”. We can’t tell for sure but based on our observations the bitbake build terminating due to the fetch timeout to the Toradex servers keeps occurring until there is nothing else bitbake can do/build. Then the fetch appears to work immediately.
This is vague information and we currently don’t have the resources required to investigate this further but maybe that tells you guys something.
We’re using bitbake 2.0 (as we’re using the kirkstone release of Yocto).

Hello @jbo,

Thanks for the update and also for reporting this issue. Could you please mark the right answer as a solution to your problem?

We do not consider this issue to be resolved.

We just setup a new build host and ran into the exact same problem again. Once again the issue of being uable to fetch the kernel sources from the Toradex servers “solved itself” after bitbake had no other tasks to run. While bitbake has other tasks to run the build will always terminate after a couple of minutes due to the fetching timeout.
As you can see here the linux-toradex task is still stuck in the do_fetch stage after over 15 minutes:

linux-toradex-5.15.77+gitAUTOINC+3592e06b1b-r0 do_fetch - 16m52s (pid 28432)

We’ll gladly mark this as solved once Toradex either fixes the underlying issue or is able to share details of why this occurs and how to fix it properly rather than just working around the problem.

Hello @jbo,

Could you please try this solution: Yocto build issue for 5.7.2 version - #3 by aditya.yantra