Linux does't get IP from DHCP on startup


I generated core-image-sato image with the OpenEmbedded to the colibri_imx6ull using the repo LinuxImageV2.7.

When the Linux start it does not get IP automatically. It’s is necessary run the udhcpc manually.
I noticed the /etc/network/interfaces doesn’t exist. So i create manually but still doesn’t get ip on startup:

root@colibri-imx6ull:/media/joao# cat /etc/network/interfaces 
# loopback:
auto lo
iface lo inet loopback
# eth0:
auto eth0

The angstrom uses the systemctl initialization. How is the correct way to get DHCP on startup?

If i run manually:

root@colibri-imx6ull:/media/joao# udhcpc 
udhcpc (v1.24.1) started
Sending discover...
Sending select for
Lease of obtained, lease time 86400
/etc/udhcpc.d/50default: Adding DNS

Best regards,

Hm, I am not really familiar with the Yocto project standard images… The network interface should appear as a regular ethernet interface, I am not sure why the core-image-sato image would not pick it up. Maybe that image is really not enabling networking/dhcp?

Is there maybe an error message during startup which is network related? I think it is using syslog, is maybe /var/log/syslog has some clue?

Maybe @koan can help?

Hello everybody,
the problem here is not the ‘Yocto project standard images’ but the Angstrom distribution used in place of the standard one used by Yocto which is Poky.
Moreover the ‘core-image-sato’ image is not part of Yocto but is into Openembedded core, that’t the reason why you have it even if you aren’t using Yocto but OE as pointed out by Toradex.

Last but not least Angstrom uses systemd configuration.
I suggest you to read this thread, but be advised that is not working on my side too.

Note that the customer is using core-image-sato and it is about DHCP configuration, not static IP configuration…

Our Ångström based images typically use connman as network configuration utility. By default DHCP on the Ethernet device works just fine for the angstrom-lxde-image or console-trdx-image.

I am not sure what networking toolingcore-image-sato is using, but I would expect that it should do DHCP by default too?

@joaopaulob can you confirm that the issue is when using the core-image-sato image?

Hi @stefan.tx,

Yes, this issue is when using core-image-sato and core-image-x11. I have not tested on other images type. I have to use the core-image-x11 or -sato because of the 128MB Flash limitation. Our application is huge.


You can also try console-tdx-image which is somewhat minimal.

Which layers are you exactly using and what distro?

Hi @stefan.tx,

I tried with the image angstrom-qt-x11-image and it word fine!
I had just remove the Qt4 binaries to fit on the module.
At the moment i will go with this image.

Best regards

Hi @stefan.tx,

I tried with the image angstrom-qt-x11-image and it word fine!
I had just remove the Qt4 binaries to fit on the module.
At the moment i will go with this image.

Best regards

Hi @stefan.tx,

Unfortunately the image angstrom-qt-x11-image doesn’ t work for me. Our application has an interface that uses Electron. When starting the Electron the graphic interface does’t appear. I think it is because the demo image remove some x11 features. I tried to check the recipe .bb but my open embedded knowledge is limited.

Any idea to enable dhcp auto-start on core-image-x11 or core-image-sato? I noticed the sshd doesn’t work too. I couldn’t connect from the host.

Best regards


do you have dhcp in the core-image-sato? If no, try to add it by doing this.


I figured out how to add X11 to the console-tdx-image.

Add the following code to the .bb

IMAGE_FEATURES += "splash package-management x11-base"
inherit core-image distro_features_check

Thanks for the Toradex Brazilian team support.

Best regards

Hi, Thanks for your feedback.