Latest UpdateTool: Syntax error (42)


We are currently trying to update our T30 modules to the latest version (2.4.b2).
We use the following procedure:

1: Flash with latest stock image
2: Install Compact Framework
3: Change needed configurations in registry
4: Copy needed files to the FlashDisk
5: Make a full backup of the module

But if we try to update this backup to another T30 module we get an error.

A command prombt with the text: syntax error (42): [
When closed the update tool show this error dialog: UDLDoUpdate: NvFlash Error

I cant attach pictures to this post? I get a “Error parsing file”?

This is the log from the UpdateTool:

UpdateTool 6.0.19 (2.0.18)

Colibri T30 1GB V1.1E SerialNo: 2905842
BCT V1.0 (800 Mhz)

First Bootloader (in Flash)
Ver:	2.4b2 (TEGRA)
Built:	16 Feb 2020 15:19:19 PM (GMT)

Second Bootloader (in Flash)
Ver:	2.4b2 (TEGRA)
Built:	16 Feb 2020 15:19:19 PM (GMT)

Image (current running)
Ver:	2.4b2 (CE 8.0, TEGRA)
Built:	16 Feb 2020 15:11:35 PM (GMT)

Loaded \USB HD\MPC2 update\winceupdatetool_6.0.19\CE8\nvflash.dll
Nvflash version 2.6 started
Loaded \USB HD\MPC2 update\winceupdatetool_6.0.19\CE8\Nv3pServer.dll
System Information:
   chip name: unknown
   chip id: 0x30 major: 1 minor: 3
   chip sku: 0x12
   chip uid: 0x0000000000000000015d4a5edd041e04
   macrovision: enabled
   hdcp: enabled
   jtag: enabled
   sbk burned: true
   dk burned: unknown
   boot device: unknown
   operating mode: 3
   device config strap: 1
   device config fuse: 0
   sdram config strap: 0

MAC:	TID=0x00142D, CID=2905842
HW:	VerMaj=1, VerMin=1, Variant=4, ProdID=23
PROD:	TestDay=738315, Testing=0, TestVer=53

Updating BCT
Sending generated BCT...RamSize=1024MB, isApalis=0, isIT=0, 800Mhz Done
file not found: Master
Sending Sync...
Sync Successful
command failure: create failed 

Tried on two different units.


Hi @TJO,

Look at the logfile, almost at the end there is a line reading:

file not found: Master

This is the issue. Check your .cfg file, it mentions a file called “Master” which probably does not exist.


The files are there. Cant it handle spaces in file names?

CFG file:
filename=Master 8.4_Bootloader.nb0
filename=Master 8.4_Bootloader2.nb0
filename=Master 8.4_OsImage2.nb0


Directory listing:

G:\master 8.4>dir
 Volume in drive G is AKR
 Volume Serial Number is 129B-C9C0

 Directory of G:\master 8.4

07-08-2020  02:51    <DIR>          .
07-08-2020  02:51    <DIR>          ..
18-09-2020  02:25             2.378 Master 8.4.cfg
18-09-2020  02:21           503.272 Master 8.4_Bootloader.nb0
18-09-2020  02:21           503.272 Master 8.4_Bootloader2.nb0
18-09-2020  02:21                 0 Master 8.4_OsImage2.nb0
18-09-2020  02:21             4.426 Master 8.4_SplashScreen.bmz
18-09-2020  02:22        25.100.716 Master 8.4_OsImage.nb0
18-09-2020  02:23                36 Master 8.4_ConfigBlock.nb0
18-09-2020  02:23           111.320 Master 8.4_Registry.nb0
18-09-2020  02:25        28.839.936 Master 8.4_Filesystem.nb0
01-01-2006  11:01                 8 Master 8.4_Filesystem.nb0.idx
              10 File(s)     55.065.364 bytes
               2 Dir(s)      89.084.416 bytes free

Hi @TJO,

I never tried to backup or restore something with spaces in the filename, but clearly it looks like it does not support that. Try replacing paces with underscodes.


It was the spaces. So I guess the update tool doesn’t like spaces


I don’t think it’s the update tool in general that has issues with spaces, i think it’s the specific .cfg file parser that is used. I might fix it in future, but for now just make sure there are not spaces in the filenames.