Latest Update Tool (v6.0.9.354 from Jan 2017) does not work on T20

v6.0.9 does not do anything when the backup button is pressed. It should open a dialog to ask where to save the files. Curiously, the release notes for this version claim that this problem has been fixed but it has not: “Fixed issue: Open dialog not shown (V2.0 beta 4)”.

The previous version v6.0.6 from August 2016 does work.

We quickly tried to reproduce this on a 2.0 beta 4 image, everything worked fine.

Could you please provide us some more details about your setup?

  • Image version you run the two on
  • Location where the update tool is started from
  • Did you update all the files of the update tool (including the 3 dlls)
  • Could you please share the serial debug output you get while running the tool? (You have to enable the debug output first).

Sorry for taking a while to get back to you, I’m working on this feature again. The latest update tool (v6.0.9) does work correctly when using the 2.0 OS image. The problem happens when using the 1.4 OS image. I’m not quite ready to move to the new 2.0 OS image yet.

@MikeS: I was able to reproduce this issue. We check how we can resolve this issue on image 1.4.

As mentioned, we have been able to reproduce the issue. The reason for this issue is that we have to make sure, that the flashdisk and hive registry is not accessed any longer. So we dismount both. This is an issue for the file dialogue, as it needs some registry information if it is loaded the first time.

Workaround

Before clicking the backup button, press update first Update to once load the file dialogue. Close it again and then click Backup. After that you will also see the file dialogue also in the backup.

We currently are checking if we can find a solution for this issue and will update the Update Tool in case we have a fix.

We have uploaded a new revision of the update tool 6.0.10 that should fix the issue with creating Backups of images older than 2.0. Please give it a try. The download is located here.

I am also seeing this problem on my unit, even when using update tool 6.0.10 and bootloader rev 2.0 and OS rev 2.0.

I just received the unit a couple days ago and updated using the files online.

When I press backup button a window flashes quickly over the tool (presumably the save dialog, although it looks a little small for that) and then vanishes. After pressing either backup button the “My Device” explorer will never fill again and programs no longer appear in the start menu. They reappear after restart.

I have tried the previous work-around of opening the update file first, with no success.

However, if I update using layout configuration rather than individual images this seems to fix the problem.

@SamCarey: Could you please let me know which Image version was installed on the devices you have seen this issue?

I used the images found here: http://developer.toradex.com/software/windows-embedded-compact/t20-t30-wec-software for windows CE7

@SamCarey: Thanks for this information. I am slightly confused: You once write about backup and once on Updatding (nb0 vs cfg). We tested both on 1.4 and 2.0 images again with the latest tool and have not been able to reproduce the issue. What could be different on your side? Any application running in the background?

As best I know I do not have any applications running in the background. I guess I might not have been clear: I began with a 1.1 beta 4 unit. I updated it to 2.0. Sometimes I updated through 1.4 since jumping all the way to 2.0 sometimes didn’t work quite right. Sometimes I did this with images since the 1.1 beta 4 version of the update tool (I forget its specific version) did not include an option to update to config files. When I did this, and then try to backup the system using the 6.0.10 update tool I find the bug described above. However, if I use a more modern tool to update the system via config files the problem no longer occurs.

Does that explain better?

@SamCarey:
As we did not test all the beta releases I quickly tested with the specific version you described. Using the latest Update Tool for all operations did not show the behavior, so I was not able to reproduce what you describe. How ever I have some assumption what may could have happen:

  • Use always the latest Update Tool. Updating from 1.1b4 to 1.4 or 2.0 with the old tool may could lead to issues you have seen.
  • Switching images with old Update Tools or NVFlash versions often lead to the fact, that you lost the serial and version number of the devices. Updating with such a setup could also lead to unpredictable behavior. This is the reason newer Update Tools ask for the serial number before doing anything operation.

Please let us know if you still see any kind of an issue.