Kiosk mode - how to disable "restore pages" popup

Hi,
I’ve used container torizonextras/arm64v8-kiosk-wait in oder to show local UI.
It works, but after “cold” restart (power button pressed) it shows the web-site with a pop-up message “Restore pages? Chromium didn’t shut down correctly”

  kiosk:
    container_name: kiosk
    # kiosk with wait-for-it
    # see ../Dockerfile.kiosk-wait
    image: torizonextras/arm64v8-kiosk-wait
    network_mode: host
    entrypoint: []
    # wait for the application 
    command:
      - wait-for-it
      - localhost:8841
      - -t
      - "120"
      - --
      - bash
      - -c
      - sleep 30 && /usr/bin/start-browser --window-mode http://localhost:8841
    volumes:
      - type: bind
        source: /tmp
        target: /tmp
      - type: bind
        source: /var/run/dbus
        target: /var/run/dbus
      - type: bind
        source: /dev/dri
        target: /dev/dri
    cap_add:
      - CAP_SYS_ADMIN
    shm_size: "256mb"
    device_cgroup_rules:
      # ... for /dev/dri devices
      - "c 226:* rmw"
    scale: 1
    depends_on:
      weston:
        # service_healthy
        condition: service_started
      portainer:
        condition: service_started

How I could disable this popup?

Best regards,
Dmitry

Greetings @jeremias.tx ,

I’ve found the idea of this kiosk container in the torizon example - exactly hier)

The reason was - the title bar in the “standard” kiosk, what I could not disable even in the “window” mode.

Is there an additional switch for disabling of the title bar?

Best regards,
Dmitry

Could you clarify what you mean by “title bar”? Do you mean the top of the window? If you don’t want the window then don’t run in windowed mode. The default with no arguments is to run the browser in kiosk mode showing only the webpage content.

Best Regards,
Jeremias

Yes, it is a top of window.

I need a fullscreen mode and I’ve used start arguments from docu

I was sure, what window-mode is the only working key for me:

--window-mode : runs the browser inside a maximized window without the navigation bar

I’ll try to start it without any parameters.

Best regards,
Dmitry

Yes please give this a try. If I modify the example compose file by removing --window-mode, then when I run the compose file the portainer app appears with no window/title-bar just the webpage content.

Best Regards,
Jeremias

Now it works, thank you!

Glad to hear!

Greetings @programmier-hirsch,

The “torizonextras/arm64v8-kiosk-wait” is fairly outdated not having been updated in over a year. Could you please try the more regularly maintained “torizon/kiosk-mode-browser:2”.

As a further hint please review the sample compose file here: https://github.com/toradex/torizon-samples/blob/bullseye/debian-container/demonstration/docker-compose.arm64.yml

This is similar to what your use-case. In this compose file we use weston and a chromium kiosk to display a local web UI, portainer in this case. With this sample compose file we’ve never had issues with “Restore pages? Chromium didn’t shut down correctly” popups.

By the way where did you get the idea to use “torizonextras/arm64v8-kiosk-wait”? Was it from some of our documentation? If so could you please tell me which so we can update it.

Best Regards,
Jeremias