Kernel Splash Screen Colibri-imx8x BSP 6.4

In 6.2 Kernel splash screen works OK after fix
this thread how to fix it

major changes

--- .config 

--- linux-toradex......bbappend 
# copy logo to drivers/video/logo/logo_linux_clut224.ppm
do_configure:append () {
    cp ${WORKDIR}/logo_linux_clut224.ppm ${S}/drivers/video/logo/logo_linux_clut224.ppm

--- u-boot enviroment fix  
setenv setup 'setenv setupargs console=${console},${baudrate} consoleblank=0 earlycon'

the same works on BSP 6.4 but I have messages on my splash screen ,
always 6 lines
It was similar in version 6.2 (at beginning) but it can be fixed

Does anyone know why there are 6 lines and not 7 or 5 ?
Or how to reduce their number to 1

This might be a hint:
Console: switching co colour frame buffer device 100x33
I counted the pixels, resolution 800x480 pix, the screen has 100x33 characters , one character 8x16 pix

Hi @MariusM,

Thanks for the question!
I’m going to investigate what causes these logs on the kernel along with the splash screen. In the meantime, could you please confirm if you could solve the issue on BSP 6.4 with the solution that worked on BSP 6.2?

After install image 6.4 I have this setup variable
setup=setenv setupargs console=tty1 console=${console},${baudrate} consoleblank=0 earlycon

After apply fix from last thread ( 6.2 )
setup=setenv setupargs console=${console},${baudrate} consoleblank=0 earlycon
I have this

My splash screen has 800x480 resolution like LCD screen
I change temporary splash image to grid (test image)
the image is cropped 96 pix in Y (from the bottom)

Hello @MariusM,

That’s an interesting question. I have tested a custom kernel splash screen for a colibri iMX8X module with a 7" capacitive display from Toradex. At least on this setup I did not see these kernel messages or empty lines popping up. I will discuss this internally with some experts and get back to you on that. In the meantime, could you please tell me what type of display you are using?

Thank you for your interest in my thread !

I have 7" AA070MC01 connected to “IRIS (V2.0) X7 LVDS connector”

Could you please check if this solves your issue:
setup=setenv setupargs console=${console},${baudrate} consoleblank=0 quiet

Hi @MariusM

If the quiet argument from Rudhi does not work it might help to just disable the console framebuffer by changing the kernel configuration. For this you need to apply the following patch:

diff --git a/arch/arm64/configs/toradex_defconfig b/arch/arm64/configs/toradex_defconfig
index 1ca4c6434e00..155680fe7e92 100644
--- a/arch/arm64/configs/toradex_defconfig
+++ b/arch/arm64/configs/toradex_defconfig
@@ -573,6 +575,7 @@ CONFIG_IMX_DPU_CORE=y

Then run:

make toradex_defconfig

In the end in your .config CONFIG_FRAMEBUFFER_CONSOLE should be disabled. Then Linux can not use the display as a console anymore.


This works for me:

setup=setenv setupargs console=${console},${baudrate} consoleblank=0 earlycon vt.global_cursor_default=0

@rudhi.tx I test it `setup=setenv setupargs console=${console},${baudrate} consoleblank=0 quiet’
it disable kernel message but I have black on bottom (96 pixels)

@stefan_e.tx I tested your solution


but after that I don’t see my splash only black screen

@Fan I tested , but it works like @rudhi.tx solution

Hello @MariusM,

Do you think you can send your display to us so we can do some tests on it?

What address ? Main office in Switzerland ?
I’ll ask my supervisor

Hello @MariusM,

I have already sent you an email with all the necessary information. Let me know if you have any other questions.