Kernel panic while booting with NFS/TFTP in DHCP mode


A kernel panic occurs while booting tdx-reference-minimal-image with NFS/TFTP in DHCP mode.

The firmware:

git remote: Index of /toradex-manifest.git
git tag: 5.7.0-devel-202206

U-Boot command used after stopping auto-boot:

env set nfs_dhcp ‘\
dhcp && \
env set serenv set serverip && \
env set fdtfile imx8mm-verdin-nonwifi-dev.dtb && \
env set kernel_image Image.gz && \
env set root_devtype && \
env set boot_devtype tftp && \
env set devtype dhcp && \
env set rootpath ${serverip}:/srv/nfs/rootfs/ca7,vers=3 && \
tftp ${scriptaddr} boot.scr && \
source ${scriptaddr}’
run nfs_dhcp

Using the following command in boot.scr

env set rootfsargs_set ‘env set rootfsargs “root=/dev/nfs ip=dhcp nfsroot=${rootpath}”’

instead of

env set rootfsargs_set ‘env set rootfsargs “root=/dev/nfs ip=dhcp”’

solved the problem.

Best regards,


Hi @petr.kupershmidt !

So, was your issue solved?

Best regards,



My post is concerning to the issue and my local solution of it.

I think It would be helpful to fix the issue in the public Git repository.

Best regards,

Hi @petr.kupershmidt

I will check internally how we can proceed with it.

Thanks for sharing :slight_smile:

Best regards,