Issues with USB connections

Hi,

I have an Apalis T30 computer on module with an Ixora V1.1A development board. The board is powered with a 12V 3A power adapter.

USB Peripheral Issue

When connecting the mouse and keyboard to the available USB ports on the Ixora V1.1A development board, they intermittently work. Sometimes they work, and other times they do not. What could be the issue, and how can it be resolved?

Remote Connection Issue

Additionally, I am having an issue with connecting to the board remotely using SSH. Here is my hardware setup: the Ixora V1.1A development board is connected directly to my laptop running Ubuntu via an Ethernet cable. Using the nmap tool, I successfully identified the IP address of the board. However, when I run the command ssh root@10.42.0.1, the connection fails with the message: “connect to host 10.42.0.1 port 22: Connection refused”. Is ssh servece shoudl run automatically on the Ixora V1.1A development board?
Could you please help me resolve the issue with the remote connection?

Thank you!

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello,

USB Peripheral Issue

For the intermittent functionality of USB peripherals like a mouse and keyboard on your Apalis T30 with the Ixora V1.1A development board, consider the following steps to diagnose and resolve the issue:

  1. Power Supply Check: Ensure the power supply is stable and capable of delivering the required current. An unstable or insufficient power supply can cause intermittent connectivity issues with USB devices.

  2. USB Port Overload: Avoid connecting high-power USB devices that might exceed the power capacity of the USB ports. If necessary, use externally powered USB hubs to connect high-power devices.

  3. Software and Drivers: Ensure that the Toradex module is running the latest version of Torizon or your specific Linux image. Updates often include bug fixes and improvements for hardware compatibility.

  4. Hardware Check: Inspect the USB ports and connectors for any physical damage or loose connections that might cause intermittent detection of peripherals.

  5. Log Analysis: Check the kernel log messages for any errors related to USB devices. You can use the dmesg command to view these messages. Look for any error messages that occur when the issue happens, as they can provide clues to the underlying problem.

Remote Connection Issue

Regarding the SSH connection issue, SSH service is not enabled by default on all Linux distributions, including some Torizon images. To resolve the issue, follow these steps:

  1. Enable SSH Service: If you have access to the board’s terminal through a direct connection (e.g., serial console), check if the SSH server is installed and running. You can typically enable and start the SSH service with the following commands:

    systemctl enable sshd
    systemctl start sshd
    
  2. Firewall Configuration: Ensure that there is no firewall blocking the SSH port (22) on the board. You can check the firewall settings with iptables -L and adjust them as necessary.

  3. Network Configuration: Verify that the network configuration on both your board and your Ubuntu laptop allows for direct communication. Ensure that there are no IP conflicts or subnet issues preventing the connection.

  4. SSH Server Configuration: Check the SSH server configuration file (/etc/ssh/sshd_config) for any settings that might restrict connections, such as allowed IP addresses or authentication methods. Ensure that the configuration permits root login if you’re trying to connect as the root user, noting that this practice is generally discouraged for security reasons.

  5. Debugging SSH Connection: You can increase

Please, also check if these links can help you solve your problem:

Kynetics Android | Toradex Developer Center.

I ran command systemctl enable sshd and got the output “Failed to execute operation: No such file found”. How to install SSH server and how to enable it?

It looks like you are using a very old OS image. Please try a newer one. If you wish to stick with the Ångström LXDE Desktop Environment, I recommend the Linux LXDE Image 2.8b6. It’s available for download here .

Hi Alex,
As I explained before I have a problem to connect to the board, no ssh, no USB ports. What will be the way to update the OS on the board? Could you please send me instructions?

Thanks!
genadiniv@gmail.com

Hi Toradex support team,
I am trying to find a way to update the Apalis T30 board with a fresh image. I am following the instructions given in this link:
https://developer.toradex.com/easy-installer/toradex-easy-installer/loading-toradex-easy-installer#put-your-module-in-recovery-mode

Under section 3, “Loading Tezi,” there is a step 3.1.1: “Put your SoM in Recovery Mode.” In the drop-down menu, there is no option for the Apalis T30. How do I put the Apalis T30 V1.1A with Ixora V1.1A in recovery mode?

Thanks!
genadiniv@gmail.com

The recommended way to flash/update the image is by using the Toradex Easy Installer. Place your device in recovery mode and load the Toradex Easy Installer over USB OTG as described here. Then, you can select an image either from the network feed or from local storage (USB/SD card). The absence of SSH access does not affect the update process. Please note that you will need a Linux OS on your development machine (a virtual machine is highly not recommended).

There is no option for the Apalis T30 because it is a discontinued (EOL) product. However, you can always use the search function. Example for you case.

Hi Toradex Support Team,

I installed the Linux LXDE Image 2.8b7, but the problem is that since the image uses an old kernel, I cannot install up-to-date packages. Additionally, the current OS uses the package manager opkg with old package indexes that only install outdated or deprecated packages. For example, the system only allows installing Python 3.5. What can be done to update the Apalis T30 v1.1A with a new, up-to-date OS with an updated kernel that will allow installing updated packages and SW?

Thanks!
genadiniv@gmail.com

Since the Apalis T30 is a discontinued (EOL) product, Toradex has stopped building new images for it. However, you are free to build your own image with a newer kernel version and packages based on Toradex meta layers and recipes