Issue with VsCode debuging, can't start container use docker-compose up

I’ve recently run into a problem using the debugger through VsCode. Running the “wait-debug-start-arm64” task in VsCode would result in an error stating that the ssh connection on the debug port was refused. I found that this was because the container was not running on the module.

The issue seems to be related to the following line of the “run-container-torizon-debug-arm”:

“LOCAL_REGISTRY=${config:host_ip} TAG=arm GPU=${config:torizon_gpu} docker-compose up -d testdebugging-debug”

If I ssh into the module and run this command, the container starts, but after a few seconds will exit with code 0.

If I instead start the container using the following docker run command, the container stays open, and I am able to use the debugger:

docker run -p 6502:6502 -p 6512:6512 -d /usr/sbin/sshd -D

My understanding is that through that docker run command, I’m effectively doing the same things as what would happen using docker-compose up.

It might be worth noting that this behavior started after using the torizoncore-builder tool to update the device tree, but to me that seems unrelated.


Module: Verdin IMX8M Plus
Carrier: Verdin Dev Board V1.1E
TorizonCore 6.3.0+build.4 (kirkstone)

Update: After stopping all containers running on the modules, I ran:

docker network prune

After this my containers would stay open when using docker-compose up, and the debugger worked as expected. This seems to be somehow related to uploading a custom images, but I don’t understand how.