Issue using the torizoncore-builder deploy... command

Colibri iMX6DL
with Viola Carrier Board Rev 1.2
Torizon version 6

Hi there,
We are currently seeing an error while trying to use the torizoncore-builder deploy… command

$ torizoncore-builder deploy custom-branch --remote-host 192.168.0.xx --remote-username torizon --remote-password xxx --reboot

The output is reporting an error…

Starting OSTree pull on the device…
Password: error: While fetching http://localhost:34501/objects/b1/f302c75879b156d68fdb4fd538cc95e80884bb011c44c6b9952c5aef9ccc4f.filez: [18] Transferred a partial file
Failed to run command on module: ostree pull tcbuilder:819ceba7fe975bd836588fee371e5500347a2791754b162867cb88465b333004

Any help would be appreciated

Many Thanks Jon

Greetings @jon2023,

This looks to be some kind of network issue on first impression. I just tried the same process myself and wasn’t able to reproduce the issue.

First of all are you running TorizonCore Builder on Windows or Linux?

Second, from your development machine can you contact the module you are deploying to via network? (i.e. SSH or something similar)?

Best Regards,

Good Evening Jeremias,

Thank you for the prompt response, and hope you are all well :slight_smile:

  1. We are running the TorizonCore build on Windows using Power Shell (WSL v2).
    Ubuntu 22.04.2 LTS… updated and upgraded.
    Connected over a local ethernet LAN connection on the same subnet.

  2. We have setup a Passwordless SSH Configuration…

  3. Rebooted the Windows PC & and Torizon device and ran through the deploy process with the additional --verbose parameter…

Is there something I can try out next which might help with the deploy process.

Many Thanks Jon

Hello @jon2023 ,
Can you check if the cause is the same as in this thread?

Best regards,

Hi Josep,

I’ll take a look and let you know if the above link resolves the issue.

Just checking one thing…

The example below includes the remove password in quotes “”. Should the password be included in quotes or is that just the way the example is written?

Cheers Jon

Hello @jon2023 ,

You can use the password without quotes, it should work

Best regards,

Hi there,

Just to let you know.
We’ve check to see if there was a clash with using port 8080, which there wasn’t.

We then tried the same command with piping the output to a log.txt file, and that seems to be working now, but still a mystery why…

$ torizoncore-builder deploy custom-branch --remote-host --remote-username torizon --remote-password torizon1 --reboot > log.txt

Output from log.txt file…
Pulling OSTree with ref custom-branch (checksum 130712c7507fde81adf0aeab69de45d7014caef15544a6315f8b54f4ba03cb98) from local archive repository…
Starting http server to serve OSTree.
OSTree server listening on “localhost:45155”.
Starting OSTree pull on the device…
Deploying new OSTree on the device…
Deploying successfully finished.
Device reboot initiated…

Hello @jon2023
Thanks for the update.
Which version of torizoncore-builder are you using?

Best regards,

Form the command line… version 3.7.0

Let me know if you need more details :slight_smile:
Cheers Jon

That’s very strange, piping the output should make no difference on the execution here.