Issue using /dev/ttyLP2 on IMX8 BSP >=5.0

I am having an issue using the UART /dev/ttyLP2 on the Apalis IMX8QP module on BSP version 5.0 and above.

I am testing on an Ixora Carrier board. Using Easy Installer, I installed Embedded Linux Reference Minimal Image 5.0.0+build.3 (2020-10-06).

From the command prompt I entered “echo hello > /dev/ttyLP2”

The device “hangs” at the command prompt until I “cntrl-c” to kill the command

I then went back to the Easy installer and loaded Apalis-iMX8_Console-Image 4.0.0-devel-202007+buld.5 (zeus)4.14.170.

I repeated the same command “echo hello > /dev/ttyLP2”

This command returned immediately and the message was transmited to the serial port that I have connected to pins X27 Pins 30 (rxd), 31(txd), and 32 (gnd)

I repeated the same tests using BSP 5.0 - 5.1 both minimal and graphical versions all of which failed.

  • Can anyone else confirm this
  • Any ideas where to start
    looking to try and fix it?

Hi @mccandlt

Thanks for writing to the Toradex Community!

There was a DMA issue which is solved now. Could you install a nightly build for the CI Feeds and check if you still see the issue?

Best regards,

Thanks for the speedy response!

I tried it with the image listed below and it looks like I have the same issue.
Toradex Embedded Linux Reference Minimal Image
5.1.0-devel-20201203+build.148 (2020-12-03)

Was that the correct image to try?


Hi guys, Any thoughts on this issue? I looked through the Device tree files looking for something obvious but didn’t see anything. If there is something that I can do to assist, I ma more than willing. Just need pointed in the right direction.


Could you please try 2020-12-14 nightly build?

2020-12-14 – Did not work - It hangs as before

2020-12-15 – WORKS!

Is there anyway that you can give me a patch or let me know what was modified? I am actually trying to use this on a custom carrier with a custom build.

Thank you for looking into this!