Issue changing U-Boot Splash

Using U-Boot 2019.07-3.0.4+g26d926eda0, I got an issue printing a bitmap to use as splash using the U-Boot console:

Colibri iMX7 # mmc rescan
Colibri iMX7 # load mmc 0 ${loadaddr} testlogo.bmp
23878 bytes read in 17 ms (1.3 MiB/s)
Colibri iMX7 # bmp display ${loadaddr}
Error: 32 bit/pixel mode, but BMP has 8 bit/pixel

I’ve tried using both 32bit and 8 bit images. In neither case I could produce an image on the screen.

Furthermore, after running

run ubiboot

the linux application runs at 16 bit depth (as planned) but the screen is running at 32 bit depth.

It seems as bmp display ${loadaddr} is changing the vidargs from 16@60 to 32@60.

Hi @Ilan_Figueiredo,

Have you followed the steps presented on Splash Screen on U-Boot?

You have to change the image to 8bit depth format:

convert testlogo.png -type Palette -colors 224 -depth 8 -compress none -verbose BMP3:testlogo.bmp

And if you are testing on one of our newest BSP 5 images, you have to enable CONFIG_DM_VIDEO=y on U-Boot defconfig for Colibri iMX7, otherwise, there will be no video output on U-Boot.

Best regards,
André Curvello

I followed the article and tried to convert a new image, and I’m still having issues.

This time I got the following:

Colibri iMX7 # mmc dev 0
switch to partitions #0, OK
mmc0 is current device
Colibri iMX7 # mmc rescan
Colibri iMX7 # load mmc 0 ${loadaddr} logo-uboot.bmp
Colibri iMX7 # bmp display ${loadaddr}
There is no valid bmp file at the given address

I’ve tried using a 500x350 pixels image. I wil test with a smaller one, but is the image size an issue?

I am using a modified BSP3.0.4 .

Loading off of eMMC should use the “fatload” command, and specify the device and partion:

“fatload mmc 0:1 ${loadaddr} logo.bmp”

If fatload doesn’t say bytes loaded, then it didn’t load anything.

I did my own uboot splash, but I replaced the image in the u-boot source (check tools/logos/toradex.bmp). You’ll also need to wire up any GPIO signals to get your LCD to light up and start showing data.

Hi @lkoziarz and @Ilan_Figueiredo,

I would recommend adding the U-Boot logo in the sources.

I did it here and it’s working.

About the backlight, that’s only valid if your backlight is inverted, otherwise, it’s expected to work normally.

Best regards,
André Curvello

Is the bmp command only supported in some versions of U-boot? I am using U-Boot 2020.04-0+git.6a8d4f758d03 (Aug 20 2021 - 10:22:00 +0000) on Colibri-imx8x, and I get an unknown command message when trying to execute the bmp command. Also, is there a way to enable U-boot video output without rebuilding U-boot from source?

I ended up adding the image to the Linux source when bitbaking a new image. This way there is no need to rebuild the U-Boot.

1 Like

Hi @rubi0030

No this is not possible, you would have to rebuild U-boot.

Best Regards
Kevin