IP is not renewwed when DHCP is reachable after getting an auto-ip before

Hi Toradex,

I trying to resolve a problem but have not managed to find a solution yet. I hoping you may know.

I have a T20 running WEC7 2.2 DHCP Enabled.
The problem is:

If I power up with a network connected to a DHCP Server, all is good (IP address assigned).

If I power up with a network connected, but no DHCP server(locally isolated switch), the T20 uses and Auto assigned IP. (which is not the problem).
If I then reconnect the switch to a DHCP server, the T20 does not get a new address from the DHCP server.Auto IP address remains.

I have tried disabling the AutoIP. This results in a IP address, but once connected to a DHCP server the remains.

My two options for recovery are the reboot the T20 or remove and refit the network cable from the T20.

I don’t think this is related to the build of OS as I have tried earlier versions and had the same result.

This seems to depend on the switch.

I tested this setup in my environment, and the IP address was renewed within a few seconds after I connected the switch to the company network and therefore to a DHCP server.

You can try to force the renewal by executing the following command on a WinCe command line:

ipconfig /renew

There are also APIs to achieve the same by code, but for an initial test I recommend to start with the simple command line approach.

Regards, Andy