Invalid parameters passed to Wince.bat when building a new SDK

I created a custom OS image WEC7 BSP iMX6 based on the original workspace files of the default OS.
The image is created (NK.bin) and I am able to run it successfully on an Iris/Colibri iMX6DL.
I want to generate an SDK for application development.
In the VS2008 Solution Explorer window, I click on the name of the OS design project to make it the active project.
Then under Project, I select Add New SDK and I get the following pop up.
I checked the environmental variables and are set to ARM7V CEBASE TORADEXIMX6BIN

Any idea who we can fix this and generate an SDK?

Thank you,

1577-sdk.png

Dear @ftp

Before I investigate the details why you get the error message, let’s step back:

  • We generate our SDKs in a way that it should not be required that you build your own (we simply include all features into the SDK, so there’s everything available when you write your application).
    So the basic question is, whether you need to Generate the SDK at all?

By the way, we also built the image itself to be very configurable, and most customers don’t need to create a custom image. Using our default image reduces the maintenance effort, as you can easily profit from any updates we do, without having to rebuild your own image. However, I assume you were aware of this and had your reasons to create your own image.

Please let me know if you still need me to investigate about the SDK error, or whether you are fine with using our generic SDK.

Regards, Andy

We added extra features to the standard image such as IE7 and therefore we need to generate a new SDK. We want to have a customized SDK.
Kindly let us know how to get rid of the pop-up message. Maybe is related to the name of the BSP with is not TORADEXIMX6 but TORADEXIMX6BIN.

Please advise.

Can you please remove from your solution the TORADEXIMX6 configurations? I think that the SDK generator takes 1st release configuration available and may be confused if you have multiple BSPs enabled in your solution.

We don’t have any solution called TORADEXIMX6, only TORADEXIMX6BIN.
I think the problem is that the SDK script is looking wrongly for TORADEXIMX6.

Please advise, thank you.

In the SDK\ folder inside your OSDesign folder you should find a file named .sdkcfg. It’s an XML file that you can open with any text editor, including Visual Studio.
Open it and search an entry like:

<Property NAME="Configuration">ToradexiMX6 ARMV7 Release</Property>

replace it with:

<Property NAME="Configuration">ToradexiMX6BIN ARMV7 Release</Property>

This should allow you to build the SDK referencing the right OS design configuration for the binary BSP.

The .sdkcfg files are created after the SDK wizard runs. In this case, the wizard doesn’t run and therefore there are no .sdkcfg
Please advise.

Actually there is no need to run the wizard for each of the SDK builds. It should be possible to:

  1. Run the wizard and create the SDK if not already done
  2. Modify the sdkcfg
  3. After running the wizard, you should have a “SDKs” item in the Solution explorer. Right click on this and click “Build”.

See also the print screen Fig. 4 on this website.