Installing Ubuntu rootfs iMX8

Dear Community;

We are planning to move from TK1 to iMX8QM processor. With TK1 we use L4T. To make the transition as easy as possible we want to use Ubuntu rootfs. To get that this is what I have thought:

1.-Download Linux Console Image.

2.-Extract the image.tar.

3.-Replace rootfs with Ubuntu rootfs.

4.-Write the image to an SD/USB?

5.-Load Toradex Easy Installer to iMX8 and flash it? Flash from U-Boot?

I am not sure with steps 4 and 5. However, before that, I am stuck in step 3. I have downloaded TEZI image for iMX8 but there I don’t see any “rootfs” folder. I think it is because it is TEZI image. I can not find iMX8 image here.

Thanks in advance.


3.-Replace rootfs with Ubuntu rootfs.

The tricky part will be any kind of hardware-accelerated graphics/multimedia requiring special downstream drivers. For any of this to work further integration would be needed. If you plan to do a headless system without any graphics/multimedia your approach may be sane. You may also find some more information here:

4.-Write the image to an SD/USB?

Nowadays, one would be using WIC images for this:

5.-Load Toradex Easy Installer to iMX8 and flash it?


Flash from U-Boot?

This legacy way of installing images is no longer supported.

Hi @marcel.tx ;

Sorry for the late answer. I am trying to load Toradex Easy Installer for iMX8 but I can not. I am following this procedure:

1.-Remove X2 Jumper.

2.-Plug USB OTG.

3.-Connect the two pads of JP4.

4.-Power on Ixora.

5.-Unplug JP4 jumper.

6.-Run recovery-windows.bat

Then the installation process goes from 0 to 100 and gets froze there:


Downloading Toradex Easy Installer…

uuu (Universal Update Utility) for nxpimx chips – libuuu_1.3.136-0-g1ecc47f

Success 0 Failure 0

3:3 1/ 1 [=================100%=================] SDPS: boot -f …/imx-boot

When the process reaches 100% Windows makes a noise similar when a USB is unplugged, but I can not connect through VNC or HDMI to the Easy Installer. I have tried with USB2 and USB3 ports with the same results. However, when I use USB3 I get this ilne:

3:3 1/ 1 [=================100%=================] SDPS: boot -f …/imx-boot

and this USB2:

1:14 1/ 1 [=================100%=================] SDPS: boot -f …/imx-boot

Any kind of help is welcomed. Thanks in advance.


Hello Andermutu,

Well, I saw some Windows users having a problem with the recovery mode. And it is usually a Problem with windows.
Is there a way that you would try it under Linux?

Best Regards,


Most useful would be the serial console output of the board as a textual file. For this one would need a suitable adapter cable:

Looking at your output it loads the initial so-called boot-container and then stalls. This could, of course, have various causes but the most likely is that it somehow fails to initialise the USB fastboot mode which would be used to transfer the actual Toradex Easy Installer.

Hello @matthias.tx,

I have tried with a Virtual machine but does not work. Usually gets stuck at 30-70% of the process. However, I think it is because USB conflict between Mac OS and Ubuntu Virtual machine.

I will consider installing Ubuntu on another machine.

Thank you,


Hi @marcel.tx

When the process reaches 100% this is what I see:

U-Boot 2018.03-toradex_imx_v2018.03_4.14.98_2.3.0_bringup+g9393e0c9bd (May 19 2020 - 21:31:12 +0000)                                                                                          
CPU:   Freescale i.MX8QM revB A53 at 1200 MHz at 56C                                                                                                                                          
DRAM:  4 GiB                                                                                                                                                                                  
MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2                                                                                                                                                  
Loading Environment from MMC... OK                                                                                                                                                            
In:    serial                                                                                                                                                                                 
Out:   serial                                                                                                                                                                                 
Err:   serial                                                                                                                                                                                 
Model: Toradex Apalis iMX8 QuadMax 4GB Wi-Fi / BT IT V1.0B, Serial# 06548474                                                                                                                  
  - SCFW b929edfe, SECO-FW 27167ff2, IMX-MKIMAGE d7f9440d, ATF bb209a0                                                                                                                        
  - U-Boot 2018.03-toradex_imx_v2018.03_4.14.98_2.3.0_bringup+g9393e0c9bd                                                                                                                     
switch to partitions #0, OK                                                                                                                                                                   
mmc0(part 0) is current device                                                                                                                                                                
"Synchronous Abort" handler, esr 0x96000007                                                                                                                                                   
elr: 000000008007ffe0 lr : 0000000080026e7c (reloc)                                                                                                                                           
elr: 00000000ffeedfe0 lr : 00000000ffe94e7c                                                                                                                                                   
x0 : 00000000fff04664 x1 : 0000000000000000                                                                                                                                                   
x2 : 00000000fd67e260 x3 : 0000000000000000                                                                                                                                                   
x4 : 0000000000000066 x5 : 00000000fff04664                                                                                                                                                   
x6 : 0000000000000021 x7 : 00000000fd6a0f40                                                                                                                                                   
x8 : 00000000fd67dfb0 x9 : 0000000000000008                                                                                                                                                   
x10: 00000000ffffffd8 x11: 0000000000000006                                                                                                                                                   
x12: 000000000001869f x13: 0000000000000200                                                                                                                                                   
x14: 000000000000003a x15: 00000000ffffffff                                                                                                                                                   
x16: 0000000000002080 x17: 0000000000000000                                                                                                                                                   
x18: 00000000fd68bda8 x19: 00000000fff045f2                                                                                                                                                   
x20: 00000000fff04664 x21: 0000000000000000                                                                                                                                                   
x22: 0000000000000000 x23: 0000000000000000                                                                                                                                                   
x24: 0000000000000000 x25: 0000000000000000                                                                                                                                                   
x26: 0000000000000000 x27: 0000000000000000                                                                                                                                                   
x28: 0000000000000000 x29: 00000000fd67e2d0                                                                                                                                                   
Resetting CPU ...                                                                                                                                                                             
resetting ...

After that, it repeats the same in a loop forever.

Thank you,


Most likely this is what you are seeing and using a later nightly build of the Toradex Easy Installer should alleviate the problem:

Hi @marcel.tx,

Using the Nightly build I can easily load Toradex Easy Installer. However, I have not understood the process of installing Ubuntu on iMX8. We don’t need any hardware-accelerated graphics/multimedia for now. Regarding to:

3.-Replace rootfs with Ubuntu rootfs.

We are talking about replacing Console-Image-apalis-imx8.tar.xz with a Ubuntu rootfs and change image.json file, right?

Thank you very much.


We are talking about replacing Console-Image-apalis-imx8.tar.xz with a Ubuntu rootfs and change image.json file, right?

Yes, exactly.

Thank you, it works!

You are very welcome.