Installing latest Arm toolchain

I am coming from a Windows background and M4/A5 (Vybrid) usage. I anticipate using the iMX8X when everything is ready. I am new to Linux so working through that. I will be developing code on a Ubuntu (18.04) platform and hoping to use Torizon when it’s ready for the Colibri iMX8X platform. Meanwhile I’m trying to build a functional toolchain based on Eclipse (which is also new to me - I used the IAR IDE). I got Eclipse installed using SNAP and it appears functional. The next task is to connect it to the ARM toolchain. I realize that there are multiple tutorials in the Toradex Developer Center, however most of there are dated and don’t really work. It appears that the ARM binaries have moved to the xPack project. The instructions (DEPRECATED > How to install the ARM toolchain? ) state the way to install the latest version is:

  $ xpm install --global @gnu-mcu-eclipse/arm-none-eabi-gcc

This worked to install the binaries into root/opt/xPacks. The question is how do I get Eclipse to recognize the compiler (and select the correct one for ARMv8)?

What is the latest on getting a version of Torizon to run on the iMX8X?

HI @prahsman

I realize that there are multiple tutorials in the Toradex Developer Center, however most of there are dated and don’t really work

What is not working for you?
What are you trying to do?
What is your application?

Best regards,
Jaski

I have downloaded and installed Eclipse (using SNAP - https://www.eclipse.org/downloads/packages/installer). This worked fine - I can run Eclipse. I then downloaded the ARM tools per https://gnu-mcu-eclipse.github.io/toolchain/arm/install/#toolchain-path and installed them in $ {home}/opt/xPacks per the instructions. I don’t know if this is the right location to get the ARM tools - is this location just for running the tools from the command line? That’s not what I want. I want get the tools to show up in Eclipse so when I start up the IDE, I can create a new C/C++ project and compile it all within Eclipse. I see that done in many online videos. Most tutorials I run across show adding software in Eclipse by doing Help>install new software which is fine but what site/respository do I steer it to get the latest version (8.3) of the ARM C compiler?

I noticed on the Eclipse plugins WEB site that there is a GNU MCU Eclipse plugin - would this work for what I want?

So I installed the above GNU MCU Eclipse plugin, which installed fine, however I’m not sure if the complier that loaded will work for ARMv8 (64-bit) cores. How would I know? Coming from using an IAR IDE with previous cores, I would like to continue doing that if possible, rather than having to do everything via command line. Any one willing to give me some guidance?

Hi @prahsman

Regarding the Toolchain, you should have a look here.

For the IDE, the trend goes to Visual Studio Code rather than Eclipse. Visual Studio code is much more light-weighted than Eclipse.
For compilation, you should use command line or self written or generated Makefiles.

If you have any other questions, feel free to ask them.

Best regards,
Jaski

Does everything work under Windows? I’m more familiar with Windows.

Hi @prahsman

We usually work with Linux only for Linux Applications. You could either use a Virtual Machine or use a docker image for Linux.

Best regards,
Jaski