Incomplete installation gstreamer1.0 for Apalis I.MX6

I have tried to add the gstreamer1.0-plugins-imx recipe to my build (LinuxConsoleImageV2.6) by adding the following to my local.conf file:

IMAGE_INSTALL_append += " gstreamer1.0-plugins-imx"

After compiling my build is not enough video encoder and decoder

gst-inspect-1.0 | grep imx
imxaudio: imxuniaudiodec: Freescale i.MX uniaudio decoder
imxaudio: imxmp3audioenc: Freescale i.MX MP3 encoder
imxipu: imxipuvideotransform: Freescale IPU video transform
imxipu: imxipuvideosink: Freescale IPU video sink
imxipu: imxipucompositor: Freescale IPU video compositor
imxeglvivsink: imxeglvivsink: Freescale EGL video sink
imxg2d: imxg2dvideosink: Freescale G2D video sink
imxg2d: imxg2dvideotransform: Freescale G2D video transform
imxg2d: imxg2dcompositor: Freescale G2D video compositor
imxv4l2videosrc: imxv4l2videosrc: V4L2 CSI Video Source

Can you please tell how to add them to my build.

How about using BSP V2.6.1 beta 1 which comes with gstreamer 1.0 pre-installed?

While colibri imx6 compiled for these files

root@colibri-imx6:~# gst-inspect-1.0 | grep imxvpu

imxvpu: imxvpudec: Freescale VPU video decoder

imxvpu: imxvpuenc_h263: Freescale VPU h.263 video encoder

imxvpu: imxvpuenc_h264: Freescale VPU h.264 video encoder

imxvpu: imxvpuenc_mpeg4: Freescale VPU MPEG-4 video encoder

imxvpu: imxvpuenc_mjpeg: Freescale VPU motion JPEG video encoder

I ran into the same problem while migrating from BSP V2.6 to BSP V2.7.
Everything builds without problems but the imxvpu-plugin is missing. I took a look at oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/gstreamer1.0-plugins-imx/0.12.2-r0/git/build/config.log which contained the line:

# using /home/duenzer/toradex/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/gstreamer1.0-plugins-imx/0.12.2-r0/git/waf configure --prefix=/usr --kernel-headers=/home/duenzer/toradex/oe-core/build/tmp-glibc/work-shared/apalis-imx6/kernel-source/include --egl-platform=x11 --disable-pxp --disable-vpu

Changing the line

EXTRA_OECONF = "--kernel-headers=${STAGING_KERNEL_DIR}/include ${PACKAGECONFIG_CONFARGS}"

in the recipe gstreamer1.0-plugins-imx_0.12.2.bb to

EXTRA_OECONF = "--kernel-headers=${STAGING_KERNEL_DIR}/include"

resulted in the new config.log

# using /home/duenzer/toradex/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/gstreamer1.0-plugins-imx/0.12.2-r0/git/waf configure --prefix=/usr --kernel-headers=/home/duenzer/toradex/oe-core/build/tmp-glibc/work-shared/apalis-imx6/kernel-source/include

Furthermore I had to append this to the local.conf:

IMAGE_INSTALL_append = "libimxvpuapi "

After these changes the imxvpu-plugin was built again. I think there is a missing dependency. In BSP V2.6 everything ran “out-of-the-box”

Hi

We disabled the VPU support for the community plugin on purpose.

At least when both the NXP/FSL and the Community plugins are installed using a playbin/decodebin approach to construct the pipeline results in assert caused by the community plugins related to vpu.

http://git.toradex.com/cgit/meta-toradex-demos.git/log/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.%.bbappend?h=morty

Max