Inaccurate touch detect

I am using STMPE811 as touchscreen driver for 10" restive screen with QT framework and EGLFS but I have a problem with touch recognition. Detected touch is offseted by few pixels in both coordinates in top left corner and almost accurate in bottom right one, but still inaccurate.
I had calibrated the screen using ts_calibrate and touch is correctly recognized with ts_test so the problem is with QT. I think it’s because QT uses evdev by default and not tslib. Is there a way how to calibrate touchscreen for evdev system using eglfs or install the QT tslib plugin?

Please have a look at existing community posts here, here and here.

Hi, thanks for quick answer. Before posting I tried the suggestions in given links but no luck. I also tried to set few environment variables

    export LD_LIBRARY_PATH=/usr/lib
    export QWS_MOUSE_PROTO=tslib:/dev/input/event0
    export TSLIB_CALIBFILE=/etc/pointercal
    export TSLIB_TSDEVICE=/dev/input/event0
    export TSLIB_CONFFILE=/etc/ts.conf
    export TSLIB_PLUGINDIR=/usr/lib/ts

to force use of TSLIB, but it did not help because when I launch the app like myApp -plugin tslib the output says “No such plugin for spec “tslib””. Could be a path to plugin folder incorrect?

I figured it out by myself. The plugin missing message was correct; in my local.conf was not defined tslib symbol so I simply added it and recompile the image