iMX8QXP Reference Multimedia Image has no video output

Installed the Reference Multimedia Image 5.0.0+build.3 (2020-10-06) using the nightly build of TEZI (Colibri-iMX8X_ToradexEasyInstaller_2.0b6-nightly-20201028). While installing, TEZI was correctly outputting from the DVI connector of IRIS to a VGA display. After booting to the Mutlimedia Image there was no video output. /sys/class/drm/ contains [card0, enderD128, version].

What do I have to do to get output on the VGA?

Greetings @sam.xz,

By default for the time being on 5.0 we have disabled the parallel RGB interface and by extension this disables the VGA output. In order to re-enable this you must modify the device tree. Fortunately we have provided an overlay that should do this without you needing to recompile the entire device tree. Please see this article for more info: https://developer.toradex.com/device-tree-overlays-linux

In this article we also actually show the exact overlay needed to enable parallel RGB for the i.MX8X. Try applying this and see if that helps resolves the VGA output.

Best Regards,
Jeremias

@jeremias.tx Thank you for your response!

I followed the guide and successfully compiled the colibri-imx8x_parallel-rgb_overlay.dtbo. Placed it in /media/mmcblk0p1/overlays/ and updated the overlays.txt. Now when booting the display gets signal and the linux logo with the kernel boot logs are visible.

But when it reaches the login prompt the screen turns black. I thought it might be a weston configuration and disabled graphical target with systemctl set-default multi-user.target and still no login prompt. Did I miss something?

That’s strange. If I recall correctly I believe for the multimedia reference image we have some kind of Qt demo app that runs by default on boot. Perhaps this demo app isn’t starting correctly and causing the black screen? Could you run top and see if there’s any processes running on boot that look like a Qt app. If yes what happens when you kill this process?

Also do you see anything in dmesg that suggests something unusual is happening?

Best Regards,
Jeremias

top reveals that Qt5_CinematicEx is running with cpu:40% followed by weston on cpu:8%.

Killing the Qt5 app while running journald -f:

Nov 05 08:16:51 dhcppc7 systemd[1]: wayland-app-launch.service: Main process exited, code=killed, status=9/KILL
Nov 05 08:16:51 dhcppc7 systemd[1]: wayland-app-launch.service: Failed with result 'signal'.
Nov 05 08:16:52 dhcppc7 systemd[1]: wayland-app-launch.service: Scheduled restart job, restart counter is at 1.
Nov 05 08:16:52 dhcppc7 systemd[1]: Stopped Start a wayland application.
Nov 05 08:16:52 dhcppc7 systemd[1]: Starting Start a wayland application...
Nov 05 08:16:53 dhcppc7 systemd[1]: Started Start a wayland application.
Nov 05 08:16:54 dhcppc7 wayland-app-launch.sh[660]: libpng warning: iCCP: known incorrect sRGB profile
Nov 05 08:16:54 dhcppc7 wayland-app-launch.sh[660]: libpng warning: iCCP: known incorrect sRGB profile
Nov 05 08:16:54 dhcppc7 wayland-app-launch.sh[660]: qt.qpa.wayland: Wayland does not support QWindow::requestActivate()

with the display still black.

The only unusual in dmesg was:

[    8.604078] mcp251x spi0.0: MCP251x didn't enter in conf mode after reset
[    8.633240] mcp251x spi0.0: Probe failed, err=16
[    8.668878] mcp251x: probe of spi0.0 failed with error -16

Full output of dmesg.

This is odd I’m unable to reproduce the same display error you’re seeing. Let me check internally and see if I can uncover anything.

In the meantime can you try installing other builds of 5.0 or even Torizon 5.0. I’m curious to see if you get the same or different experience on different versions. As a reminder when re-flashing any 5.0 image you’ll need to re-apply the overlay to re-enable parallel RGB. Make sure to note any differences and what version they happen on.

Best Regards,
Jeremias

Another tip I got from the team was sometimes the backlight doesn’t properly initialize after the change.

Can you also try force enabling the backlight via the following:

echo 4 > /sys/class/backlight/backlight/brightness

Also check the “bl_power”, it should be “0”
cat /sys/class/backlight/backlight/bl_power 0

Otherwise, set it to 0:
echo 0 > /sys/class/backlight/backlight/bl_power

Give that a try and let me know as well.

Best Regards,
Jeremias

All installed with Colibri-iMX8X_ToradexEasyInstaller_2.0b6-nightly-20201028

  • Kynetics Android Pie for v1.0B - 1.0-SNAPSHOT-20190823
    • Display works and shows android UI.
    • /sys/class/drm: card0 card0-DPI-1 card1 renderD128 version
    • Can’t play video files. Tried .mp4 and .mkv on VideoPlayer and CactusPlayer.
  • Reference Mutlimedia V1.0B - 5.0.0-build.3 (2020-10-06)
    • Linux logo and logs then black output
    • /sys/class/drm: card0 card0-DPI-1 renderD128 version
    • /sys/class/backlight/backlight/brightness was 4, setting it to 4 had no effect.
    • /sys/class/backlight/backlight/bl_power was 0.
  • TorizonCore with evaluation containers for V1.0B - 5.1.0-devel-202011+build.4.container (2020-11-06)
    • No output
    • /sys/class/drm: card0 renderD128 version
  • TorizonCore V1.0B - 5.1.0-devel-202011+build.4 (2020-11-06)
    • No output
    • /sys/class/drm: card0 renderD128 version
  • TorizonCore V1.0B - 5.0.0-devel-202010+build.3 (2020-10-08)
    • Shows torizon logo, then black output
    • /sys/class/drm: card0 card0-DPI-1 renderD128 version
    • /sys/class/backlight/backlight/brightness was 4.
    • /sys/class/backlight/backlight/bl_power was 0.
  • Colibri-iMX8X_ToradexEasyInstaller_2.0b6-nightly-20201028
    • Display works.
    • /sys/class/drm: card0 card1 card1-DPI-1 renderD128 version

So the only images that produce output are Android and TEZI. I noticed on both of them there is an extra card* in /sys/class/drm.

Hi @jeremias.tx and @sam.xz,

As we got console and Linux logo in the boot process, I think we are halfway done.

The blank screen after user prompt is really curious…
Yes, he should be seeing the Qt5-demo app running.

@sam.xz, the “warnings” on mcp251x are expected, if you don’t have this CAN SPI controller. But it doesn’t affect anything.

Please, try to change the screen brightness and let us know if that worked.

Best regards,
André Curvello

Thank you both for your responses! The brightness settings are already at the values @jeremias.tx suggested. I tried setting them but with no results. I have another comment with more info pending for review by a moderator.

Hi @sam.xz,

We have internal reports that the video output is working fine in the Monthly release for BSP 5.1, for Colibri iMX8X 1.0B, and Iris carrier board V1.1B.

You may have to enable the CI feeds for Continuous Integration in the Easy Installer.

Could you test it again?

Best regards,
André Curvello

Used Colibri-iMX8X_ToradexEasyInstaller_2.0b6-20201102 to install Toradex Embedded Linux Reference Multimedia Image for V1.0B HW - 5.1.0-devel-202011+build.4 (2020-11-02). On first boot the monitor did not receive a signal. I edited the overlays.txt to use the provided overlay fdt_overlays=overlays/colibri-imx8x_parallel-rgb_overlay.dtbo. After rebooting, the linux logo and logs came up, then black. top reports Qt5_CinematicEx is running.

@andrecurvello.tx @jeremias.tx Since you have a working device, you could really help us out if you can verify that the parallel rgb can run a display at 1280x800@30Hz.

Hi @sam.xz,

We are checking that, and as soon as possible we’ll give feedback.

Best regards,
André Curvello

HI @sam.xz,

I checked this with the image TDX Wayland with XWayland 5.1.0-devel-202011+build.4 on Colibri iMX8X 1.0D and it works fine.

Did you set the U-Boot variable defrags to the following value video=DPI-1:1280x800-16@30D?

Best regards,
Jaski

@jaski.tx We got a V1.0D unit and are experiencing the same behavior. If the image you used is available in TEZI, please tell me the exact name, else could you provide a link to that image?

Hi @sam.xz,

I have a Colibri iMX8QXP V1.0D as well, and I tested it with an Iris V2.0 and DVI-VGA adapter, and it’s working fine.

In my case I used the following image:

Toradex Embedded Linux Reference Multimedia Image 5.1.0-devel-20201208+build.152.
Please be aware that you need to enable CI Feeds on TEZI.

But you can use any image newer than that for your tests.

See the pictures below.

[upload|SdkN7zfDUQQwH34k74MEEdQq/pA=]

[upload|GR7HpZxX+6fyvCxAzuo6gvmbDFk=]

[upload|/BMjYavqQOsxQdoEHurTk3yzSPk=]

[upload|jgPvEkAI/x7qzKLnVaEzlUEWtXc=]

Please try that and tell us if it worked.

Best regards,
André Curvello

@andrecurvello.tx Thank you for your very detailed response! We tried on a different monitor and it looks like something is displayed when the Qt5 demo is running, but we have to increase the contrast to see it since it is extremely dim and dark. Increasing the resolution makes the image even darker. Could this be due to our Iris board being V1.1B? Also, could you please verify that the image 20201209-162845.jpg you provided is running at 1280x800? It looks more like 4:3.

Hi @sam.xz,

I don’t think this could be related to the Iris V1.1B.

Possibly, could be related or to your monitor or to your DVI/VGA adapter, or even by your VGA cable.
Could you try changing these?

I think that the resolution may be 1280x800, but I haven’t changed anything.

It was a clear flash and boot process :slight_smile:

Best regards,
André Curvello

Since TEZI shows up correctly, it’s probably not a cable or adapter issue. The very dark image could be an artifact of requesting an 8bit color from a 6bit circuit. Since we don’t have access to an Iris 2.0A, could you check on an Iris 1.1B to see if you get the same dark image?

Hi @sam.xz,

Happy new year!

I managed to test my Colibri iMX8QXP on an Iris V1.1A, and surprisingly, I don’t get video output after system boot.

I can get video output with Easy Installer, and I can even see the Linux booting messages, but when it was supposed to show the Multimedia demo, blank screen.

I’m discussing internally if there is an explanation for that.

And, then, considering that the Iris V1.1* was discontinued, I leave here also a suggestion for you to order an Iris V2.0A, if possible.

Best regards,
André Curvello