IMX8QP 2GB WP V1.1B Recovery Mode


Following the instructions for entering recovery mode for the IMX8, I seem unable to do so. I am using an Apalis Eval Board V1.1C with an IMXQP WB 2GB V1.1B.

I have the following configuration:

  • Serial UART cable plugged into RS232
  • USB Cable plugged into USB01_CL

With power off, I shorted the two pads as shown in the instructional diagram, powered on, and held the short for greater than 6 seconds. The red LED light stays on as long as the USB01_CL / USB01 is not plugged in. Once I plug into the OTG port, the boot sequence resumes and recovery mode is not entered, and I cannot utilize the Easy Installer to load new images, etc.


Have you tried to keep a USB cable plugged in while you entering the recovery mode?

Yes. Same result.

And what is a result? Module start booting when you remove tweezers from module’s recovery pads or immediately when you apply power?

Ah. Same result as before. Upon power on with the short applied, the module powers up with LED10 illuminating and then “hangs” (which I assume is recovery mode?). After 6+ seconds, I remove the short, and the boot process continues after a couple seconds.

This occurs whether or not the OTG port is connected before power on or not. If the OTG port is not connected before power on, it appears to remain in recovery mode, but then when connecting to the OTG port, the boot sequence resumes with no recovery mode.

It’s almost as if I need to continue applying the short, which of course doesn’t make sense, but that’s what it seems like.

Hi @grh,

For the Recovery Mode, we recommend the usage of a direct USB connection between the module’s OTG port and your computer. So, I don’t know if you are using a Hub or not, this is just a recommendation.

I would also recommend you try a different USB cable.

@gustavo.tx any suggestion here?

Best regards,
André Curvello

Hi @andrecurvello.tx

No, I am not using a Hub; I am using a direct connection. I have tried 5 different cables as well, so still not sure what the issue is?



So, I should mention that I am doing all these things in our virtual machine build system running Ubuntu, which itself is running on a Windows host.

I just now attempted all this on the Windows host and got slightly different behavior, although still not as it should be:

  • The SOM appears to have entered recovery mode (meaning, LED18 is illuminated…sorry, earlier I said LED10 but meant “the LED next to the SOM”…my eyes are not what they used to be apparently)

  • I connect the board to the host Windows machine via the OTG port, and I get a notification that says “USB device not recognized”

  • However, the board DOES NOT just continue booting into the reference image; it appears to stay in recovery mode

  • When I run “windows-recovery.bat” it just sits there saying “Waiting for known USB device to appear” and never seems to recognize when I’m plugged in to the OTG port

  • I’ve tried this on both USB01_CL and USB01

Does this mean I need some kind of USB driver update on the Windows host?

Further update: I had forgotten the SD card when I made the attempts in Windows (I did not have an SD card inserted when attempting in the virtual Linux environment). When I removed the SD card and attempted to reenter recovery mode, it worked.

When I try again to replicate in the virtual Linux system, same issues: recovery mode appears to be entered -as long I hold the short- but then when I remove the short, the boot sequence continues normally.

So maybe this a virtual machine issue? I’m using Virtualbox Version 6.1.6 r140961 running Ubuntu 18.04.5 LTS…


Yes, using recovery tool from Virtual Machine is not recommended. Please use a native Linux or Window box.